Can't disable pre-arm checks

I am trying to do some bench testing indoors.  I can not get the Pixhawk (v3.3) to arm no matter what I try:

1)  Disable prearm checks

2)  Make all flight modes non-gps modes

3)  Change GPS_TYPE to zero (meaning no gps)

4)  Change AHRS_GPS_USE to zero

After (1) did not work (I verified that writing the parameters worked), I added on 2, 3, and 4.  No luck.  I still get one type or another of GPS errors (speed, whatever) when I try to arm.  If I go outside (getting a good GPS signal), arming works.

Ideas?  Thanks...

Bill

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • hello im really confused and it drive me crazy ( I CANT ARM MY QUAD ) frame type : tarot 650 Apm 2.6 esc and motor calibration : done radio calibration : done compass and accelerometer .. calibrated several times i received many pre arm checks messages like GPS HDOP / BAD VELOCITY AND SO ON i did my best to solve it and i only could solve GPS HDOP but is cant arm anyway i end up disable pre arm checks just to see if i can arm or not ... and i still cant arm any ideas .. help! suggestion perhaps

  • MR60

    To help and inform other users who will have the same experience, the problem is not a bug but a "hidden feature" introduced in version 3.3.x:

    -in previous versions you would disable the pre arm checks in the corresponding menu (standard params) of mission planner

    -in version 3.3.2 (and I suppose future versions?) : doing the above step , AND you must also go in the full parameters list or tree or geofence menu , look for the parameter "Geofence enable" and set it to zero.

    I have tested it succesfully like that.

    • Thanks, your note helped me out 6 years later on version 3.4.6 using Mission planner 1.3.75. The parameter must now be set to 10 and it is now called FENCE_ALT_MAX (default 100). This must be set even if the geofence is disabled.
      Super annoying - you saved me a lot of time - cheers.
  • You probably need to disable the fence (I can't remember the exact name of the parameter). 

    • That's the solution: disarming GeoFence.

      I raised this issue here, there are some controversial thougths: https://github.com/diydrones/ardupilot/issues/3220

      • MR60

        Thx for the info. Too bad this new behaviour in 3.3.x remained undocumented.

        Further I do not see any reason  to not show explicitly, geofence with pre arm checks: I want freedom to configure as I wish to and be able to disable pre arm checks when I need to. The non developer user can't know from thin air how the code has been modified introducing new hard links between parameters.

  • MR60

    Hello,

    I noticed the same bug. it is impossible to disable the prem arm checks, although the parameter is set.

  • I Noticed same thing. Only with 3.3.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23
DIY Robocars via Twitter
Oct 23
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
Oct 18
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13
More…