Cannot upload APM software

Hi all


As of today I am unable to upload firmware to my APM.  Any help would be appreciated, here's the data I've got.


I have two APM units, one for my quad and one for a fixed-wing I am building.  As of a couple of days ago the quad unit worked fine, the last change I made was soldering in voltage monitoring leads and resistors.  After that it could still connect.  Today when I went to try .44 I chose the right port and speed and selected "upload firmware."  The mission planner hangs for ~20 seconds at "detecting APM version" and then errors out with the message "Can't detect your APM version, please check your cabling."  


I cannot get into the CLI at all, it hangs on "Opened COM port" with the switch in SETUP mode.  With the switch in FLIGHT mode it spits out a ton of garbage, as I recall is normal.


If I switch the shield from SETUP to FLIGHT mode and connect via MAVLink, it appears to work fine, the flight data screen shows sensor input.


My other APM unit works fine.  I tried swapping shields and the other shield on the quad's arduino gives the same error, while the quad's shield on the other arduino works fine.


Interestingly I can connect through MAVLink via my telemetry as well.


Any ideas?  It sure seems like the quad's arduino somehow got messed up, but I've no idea how to confirm that beyond what I've already done, nor have I any idea what could have caused it.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21