I'm running 2.7.1 (Mavlink 1.0) on an APM1.4.  Just turned on the MinimOSD with the 3DR (900mhz) radio at the same time.  The OSD comes up, but with no data (e.g. 0 degrees on the heading).  3DR radio works fine.  I left the TX line off the MinimOSD connector, as per the wiki.   This setup worked with Mavlink 0.9. 

As a test, I disconnected the 3DR radio connector and took the TX line out of the connector and put it in the MinimOSD connector and the OSD worked fine.

I'm wondering if the serial port oilpan driver cannot handle two loads??? 

Has anyone seen (or know about ) this issue??

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Just fgured this out and am posting in case someone else has the issue.  On an APM1 with both 3DR radio and MinimOSD connected all looks OK but no telemetry is displayed.  Here is my error in thinking and what I did to get it to work.

    You must first connect the 3DR radio with MP.  I can even power the APM from USB (APM1, rememeber), but I must connect MP and APM FIRST usng the 3DR radio.  Until I connect them, I see heartbeats but no telemetry.  Once MP and APM is connected via the 3DR radio, all works fine.  If I try to connect via USB, no telemetry.  But if I again connect via the 3DR radio, all works.  And one other thing - once I connect via the 3DR radio, I can disconnect MP and all continues to work.

    So to sum up, you must FIRST connect MP to APM via the 3DR radio to get the MinimOSD to display telemetry.

    At least, that worked for me. 

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…