Cant detect your APM version. Please check your cabling

We just received and soldered up a new APM 2 autopilot.    We were able to upload the Audocopter V2.5.4 once.  

Now we can not connect no matter when we do. We get the message, "Cant detect your APM version. Please check your cabling".  

We tried everything including setting up an entire new computer with the software .... and we get the same message.

Does the "cabling" go bad?

Is there a setting on the card that needs to be reset besides the reset button (Which we have tried several times)?

Thanks for any help anyone can give.

Richard Eis P.E.

Cant detect APM Version. please check cabling.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • This seems to be a common problem. We had the exact same problem. Initially we thought it was a bootloader issue. Turned out a component fell off, sent back for repair.

    You can try to reflash with a manual compile of arduplane or arducopter with Arduino relax patch. Or reload the firmware on the 32u2 chip(instructions on google code wiki) if either works board is probably fine. If it doesn't work it probably needs to be sent back.

    Good luck
This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21