Cant get APM 2 to install drivers

Having a problem with my new APM 2 board. I have installed mission planner as per instructions and that went fine. I then plug in my APM 2 vie a usb cable and it says cant find driver,so i manually look for the driver in the device manager browser window and find the folder marked driver.This folder wont open but it allows me to click ok so that is the location the computer is pointing to to search for the driver. I then click next and it says "Hardware not install as windows cant find software". The strange thing is if I look for it on my computer and look in the driver folder the driver Inf file is visible there. This happens on the 3 PCs i have triad it on with the same result every time. 

The board gives a blinking blue light that goes solid after a while and a solid green light.I have also downloaded the driver individually with the same outcome. I have DirectX and .net framework installed so its not and issue with them i dont think. 

I am running windows xp and have also tried it on a vista computer and a windows 7 computer. In the device manager it is shown as a yellow ?

I have also been over the soldering with a magnifying glass and that all looks in order so really scratching my head now as to whats wrong.

Running off Usb power but have also tried with esc BEC and 

Any advice would be much appreciated please.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


This reply was deleted.