Channel 6 PID Tuning Problem

I just can't seem to get the channel 6 PID tuning to work properly despite spending many many hours over several days reading the wikki and searching posts and fiddling with settings, hopefully someone can help, I'm getting really frustrated.  I'm using firmware 2.9.1 and Mission Planner 1.2.46 and a Turnigy radio with er9x.

The problem is that on the config page mission planner seems to be ignoring the min/max values I enter for the tuning. For example for rate P, I set min to .05 and max to .15 but when I make adjustments with the ch6 knob it stays a 0 for the first half rotation then rapidly increases to a max of .16.  It does the same behavior no mattter what I set the min/max values to (I tried many)  and it behaves the same (ignors the min/max values) for other PIDs.

I am communicating with the 3DR radio (not usb), the props are off and I does not seem to matter if the quad is armed or disarmed. My radio is calibrated properly and CH6 works fine on the radio calibration page.  What I find really weird is that it works perfectly in CLI mode using test: tune, smooth as butter and min/max values are correct as I set them in MP.  So if it works in CLI why won't it work on the Arducopter Config page?.

Here is a screenshot of what I'm seeing, no matter what I do the max value goes to .1600 and for the first half rotation of the knob it stays at zero even though min is .05 

Has anyone seen this before? Am I doing something wrong? Is there a bug in this version of MP?

3691020550?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I FOUND THE BUG, finally!  I stayed persistant since it was driving me crazy, after screwing around with the radio awhile I went to changing random things in MP that shouldn't make any difference.  I found that if I disabled the camera gimble settings it suddenly worked as it should, enable camera gimble and it goes back to behaving badly.  I had the camera gimbal set up previously but have since changed the motors/ props to handle the camera weight, then I couldn't tune the new setup.  Thanks James and Ali for chirping in, I was beginning to think I was alone here, I believe disabling the camera gimble will solve your problems too. Right now my ch6 knob only works for half its travel, but at least it works, this might be the radio, I'll look at that next.

    This issue really should be in the wikki instructions or be fixed, anyone know how to properly report this?

    • I had same issue. Re-calibrating radio in MP helped.

    • 7

      This is probably a bit late, but a great find. Just experienced the same problems when trying to tune my APM 2.5 with the 3.1.3 firmware. The minimum and maximum limits of the tuning knob had no effect until I disabled the outputs to the role and pitch axis of the camera gimbal. Then everything started working perfectly :-).

      Apparently this was never reported as a bug?

  • Still getting frustrated, I updated to MP 1.2.50 and same problem. Also changed ch 6 endpoints on Tx from -100/100 to 0/100 which simply changes the pwm output range  (990 to 1500), changed to a different pot on Tx, changed endpoints to  -90/90, recalibrated several times but same result every time. 

     I really dont think its the Tx since it works like a charm in the CLI test/tune.  Why on earth is MP completely  ignoring the min/max values for the Ch6 option?

    I set CH6 Opt to CH6_RATE_KP. Set a min value of .05, max value of .12, "write params" to APM.  If I turn the pot all the down and "refresh params" I get 0 for Rate P (not .05), if I turn it to the halfway point and "refresh params" still 0, if I turn it all the way and "refresh params" I get .16 (greater than my max value).  Its the same every time, no matter what values I use for min/max.  It is also the same result (different numbers) for all the other PIDs. 

    Using the CLI test tune feature, the min value is correct with Ch6 knob turned all the way down, the max value is correct turned all the way up and all values in between are smooth and scaled correctly.

    Is there possibly something else in MP that is blocking me from using the Ch 6 tuning? Am I doing something wrong? Anybody??

  • I had the same problem until I went into my transmitter settings and made sure the AUX channels "end points" were set to 0 -100  

  • How did you calibrate the radio? Via Cli or MP? There were problems with the CLI method in previous versions of AC. When you look at the Mavli k Parameter list, what does it give you for the radio channel limits?

    There is a newer version of MP available. Have you tried to update?

    Otto
This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
5 hours ago
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
5 hours ago
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
11 hours ago
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Saturday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Saturday
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Friday
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Thursday
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
DIY Robocars via Twitter
RT @gclue_akira: 柏の葉で走行させてるjetracerの中身 #instantNeRF #jetracer https://t.co/giVvuE4hP7
Jul 4
DIY Robocars via Twitter
Cool web-based self-driving simulator. Click save when the AI does the right thing https://github.com/pncsoares/self-driving-car
Jul 4
More…