I'm using an APM2 from the first batch and am, having some trouble with the compass/magnetometer enable setting.  The board set has been flying and I'm just investigating the compass as prep to moving it to a quad.

I can check Planner's enable box for the compass and that changes MAG_ENABLE to "1". So, I write params to the APM2, then disconnect and reconnect Planner.  After re-reading the params, MAG_ENABLE is still set to 1.

Now I power down the plane and reconnect the battery.  Next, reconnect Planner and it reads the params.  MAG_ENABLE is now "0", and Planner's compass checkbox is unchecked. 

When I use the CLI it tells be that "Compass Initialization Failed!" for an HMC5883L device.

Is this an RTFM, a bug or a hardware fault?


Views: 746

Reply to This

Replies to This Discussion

I have exactly the same issue with mine. Let me know if you have found anything.

Now I'm trying to discuss this with support.

Problem solved!!!

kind of stupid but my APM 2.0 board was mounted to close to the canopy magnets... (see the picture).


Thanks for your update.  I guess you replaced the magnets with velcro and that worked. 

No one ever got back to me on this problem. In my case, the chip is bad. It's probably not repairable unless you have a SMT rework station available (and I do not).  This chip is really more applicable to heli/quad use and I'm doing fixed wing.  It's only advantage in fixed wing would be holding initial heading with auto-takeoff until the gps heading comes alive.

Still would have been classy to have "some" response from support.

Try to send them an e-mail they were pretty responsive with me. (help @ 3drobotics . com).

After 20 e-mails back and forth they offered RMA with a prepaid FedEx label.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service