Hello everyone!

I'm working on a project related to autonomous and piloted flight and image recognition missions of a hexacopter, which is being very difficult due to a lot of problems to configuring the command for "Yaw" in the radio with Mission Planner.

After installing the Pixhawk 2.4.8 at my drone, I did all the calibrations (for the compass, accelerometer, radio, etc) and configured my radio Flysky fs-i6 for the flight mode 2. This radio has 6 main channels and 2 auxiliary channels.

The control for "yaw", is set for the channel 5 at the RCMAP (Input Channel Mapping) . This control corresponds to the channel 4 of my radio (that is the horizontal control of the left stick of my fs-i6).

But, when I try to fly my drone, I can see that it doesn't respond at all to this horizontal-left control, as if it wasn't configured.  Also, it is behaving very strangely regarding to the yaw movement: even if I can't change the yaw state with my remote, the take-off starts with a pronounced yaw movement, that usually leads to crashing in walls and broken propellers.

Do you have suggestions on how could I solve this issue? Help.

Thanks a lot!

Views: 116

Reply to This

Replies to This Discussion

Hi, Alberto!

Thank you for your answer.

I had indeed changed the rc-map parameters so that the channels on my remote correspond to these in the Full Parameter Tree:

RCMAP_pitch : 3

RCMAP_roll: 2

RCMAP_throttle: 4

RCMAP_yaw: 5

When I do this, all commands work properly (on mode 2 of my radio) , except for yaw. After that, I noticed that the channel 5 is set to be the one responsible for changing flight modes. I tried to change it for the radio 6 (in the FLTMODE_CH), but after pressing the "Write Params" button, nothing happens (ch 5 is still changing modes instead of controlling yaw as it supposed to).

So, after that, I tried to set RCMAP_yaw for 1, but still nothing happens, as if channel 1 hadn't any function.

PS: one thing that I don't understand is why, at the FailSafe Mode page at Mission Planner, the Radio 4 is responsible for controlling yaw, while it is the Radio 5 in the Radio Calibration page, given that, in the RCMAP, RCMAP_THROTTLE is 4.



Alberto Vila said:


well, i never had that kind of problem, but if you have a pwm to ppm converter conected to

your receiver, maybe you can changue the order of your channels there, just by conecting it

in a diferent order willw you have the original configuration...

i would like to see a video of this problem.


Livia Fragoso Pimentel said:

Hi, Alberto!

Thank you for your answer.

I had indeed changed the rc-map parameters so that the channels on my remote correspond to these in the Full Parameter Tree:

RCMAP_pitch : 3

RCMAP_roll: 2

RCMAP_throttle: 4

RCMAP_yaw: 5

When I do this, all commands work properly (on mode 2 of my radio) , except for yaw. After that, I noticed that the channel 5 is set to be the one responsible for changing flight modes. I tried to change it for the radio 6 (in the FLTMODE_CH), but after pressing the "Write Params" button, nothing happens (ch 5 is still changing modes instead of controlling yaw as it supposed to).

So, after that, I tried to set RCMAP_yaw for 1, but still nothing happens, as if channel 1 hadn't any function.

PS: one thing that I don't understand is why, at the FailSafe Mode page at Mission Planner, the Radio 4 is responsible for controlling yaw, while it is the Radio 5 in the Radio Calibration page, given that, in the RCMAP, RCMAP_THROTTLE is 4.



Alberto Vila said:

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service