Connect Raspberry PI to Px4


I am trying to connect a Raspberry Pi 3 to Px4 Arducopter V3.4

I am following this instruction:

My problem is when I connect RPi 3 to Px4 and do the command : --master=/dev/ttyAMA0 --baudrate 57600 --aircraft MyCopter

In the manual, 3 files should be sent from Px4 to RPi3 (mav.parm, flight.tlog, flight.tlog.raw). But in my case, mav.parm (a text file with all the parameter values from the Pixhawk) is missing. So I think that why I can not do any command on PX4

I attached a result photo below, is there anyone who know about this problem please support me to overcome it




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey bro, check out this:

    this is a kind of bug from pi 3, follow that instruction could figure out the problem, good luck!
  • Hi Anh,

    I have same situation like you, do you have any improve? I am also using RPi 3. I tried to receive some mav data from pi3`s UART0, but i got nothing. I also tried to sand some another data via UART0, I got the data this time, so the UART0 is work, looks the mav command not work.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25