Connection APM2.6 to Raspberry Pi 3 with Mavproxy

Early, I worked with APM2.6 with Raspberry Pi B+, Raspberry Pi A+ and all works fine.

Now I try to connect APM2.6 to Raspberry Pi 3 and Raspberry Pi Zero and I obtaned the next problem:

1) I tryed to connect with usb port and command

sudo --master=/dev/ttyACM0 --baudrate=115200 --out= --cmd="wp load mission.txt"

2) I tryed to connect with telem port and command

sudo --master=/dev/ttyAMA0 --baudrate=57600 --out= --cmd="wp load mission.txt"


sudo --master=/dev/ttyS0 --baudrate=57600 --out= --cmd="wp load mission.txt"

And allways I see next result:

pi@raspberrypi:~/f1/go $ sudo --master=/dev/ttyACM0 --baudrate=115200 --out= --cmd="wp load mission.txt"

Connect /dev/ttyACM0 source_system=255

Loaded 5 waypoints from mission.txt

Log Directory:

Telemetry log: mav.tlog

MAV> Waiting for heartbeat from /dev/ttyACM0

So, mavproxy writes, that waypoints are loaded! But, when I check it using Mission Planner I can't see points. It writes, that points are loaded, but they are not.

Help me please to find the solution! Thank you!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Also I think you're trying to access the wrong device - ttyACM0 isn't correct for raspberry.  Try ttyAMA0 or ttyS0.  Ideally you should disable the bluetooth and use AMA0 as detailed in the link you've posted or here:

  • MAV> Waiting for heartbeat from /dev/ttyACM0

    ^^ This means you haven't got any connection to the FC yet.  'Loaded 5 waypoints' just means mavproxy has loaded them from the file mission.txt on your disk, not that it's loaded them to the FC.

  • Stephen, thank you for answer, but

    when I try to upload mission inside my python script, it's looking like this:


    child = pexpect.spawn("sudo --master=/dev/ttyACM0 --baudrate=115200 --out=")

    ..waiting for heartbeat

    child.send('wp load /path_to/mission.txt\n')

    it is not working too,

    but with RPi A+ and RPi B+ with Raspbian Wheezy it works fine.

    Here is thread about same problem, but they hasn't find solution, only downgrade from RPi3 to RPi2 =)

  • It's a bug in MAVProxy - you can't load waypoints via the --cmd="wp load mission.txt".

    There's a bug report at

    cmd not seeming to work for wp load · Issue #142 · ArduPilot/MAVProxy
    I have tried on 1.4.11(win), 1.3.13(win) and linux (latest) and I can't seem to get this to work. The command I have tried is "--cmd="wp load [fi…
This reply was deleted.