connection problem after wizard fail

Hello drone enthusiast.

I`m from Austria so please don`t mind my grammar or spelling.

I have a big problem with my APM2.6. after canceling the wizard because i forgot to configure my remote control. I can still update the firmware but then can`t connect to the APM to configure it. I tried to fix the problem for 3 days now while following discussions of others describing nearly the same problem,

until now i tried all different baud rates (set in MP and device manager, I know 115200 for USB and 57... for 3dr radio are right), uninstall and reinstall MP and drivers, rebooted laptop, tried older versions of MP and ARDUcopter, another laptop, different cables and com ports. 

My laptop recognizes the APM as COMxy Arduino Mega 2560 (xy depends on COMport). It seems that I can update the firmware but it then can not boot the program to configure the parameters in the program. I always get the message "no heatbeat package received" after running MAVlink into time out.

the message written in german in picture 2 means check port or baud rates. a device connected doesn`t work.

I´m studying mechatronics so i have background of computers, electric circuits and so on.

please give me any suggestions to solve that problem

greetings Ben

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • This is the gps i am using. Chinese one 30 dollars with gps and compass.

  • I have heard people have had this problem when the 3.3 volt regulator goes. Disconnect the gps and if it has a magnetometer on it disconnect it too and try starting it up. Try a eeprom clear. Can you connect to it in the terminal?
  • I'm having the same problem. plz help?
This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21