Looking For Advice With A Broken Motor [SOLVED]

One of our motors (ArduCopter Hexa Ready to Fly) has stopped working correctly and we were wondering if anyone had some pointers for how to solve this.  It stopped working in the field after about 30 minutes of use, when switching out for our 3rd battery.

Now, whenever it starts up we get "musical tones" + "3 beeps (for 3 cell lipo)" + "1 confirmation beep".  Then 5 of the motors are still, but the 1 broken one that doesn't spin during flight keeps jerking back and forth, and the Hexarotor beeps repeatedly! Here is a video of it:

http://youtu.be/Slw0QDyVnIM

From reading around, it seems this could be due to either (1) something not plugged in or (2) a radio problem. We've taken apart the bottom to ensure everything is plugged in, and put it back together and are still getting the same behavior. Yesterday was the first time we used the XBee telemetry if that matters, and the telemetry works fine.. Any help would be greatly appreciated. Thanks.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Thanks for everyone who helped me out. Here is how I fixed it: Forget all the resoldering and replacing of components... it is a very simple problem with the throttle on the transmitter and values being out of bounds somehow (still not sure why).

    Using the DX8, the main menu looks something like this if you scroll all the way down:

    3692543564?profile=original

    Click on monitor, and then you get this:

    3692543664?profile=original

    The problem is with the "THR" channel.  I'm still not sure why... but by moving it just a few ticks, it will stop beeping.  For me, I adjusted it to -94 with the battery plugged in and the beeping stopped immediately.  

    It still beeps on boot each time, but by manually adjusting the THR from whatever it was set at during boot, for some reason it stops beeping and I can fly. Not sure why but at least a partial fix... 

  • After working on this the past few days we still cannot get it working.  If anyone with some experience could shed some light on this it would be very helpful, as I am not sure what else to try. What does that rapid beeping in the above video signify?

    We took the 3 phase power output from the ESC of the the motor that wasn't working, and connected it up to another motor, and that motor exhibited the same behavior shown in the video.  So we ruled out the possibility of a motor failure.  The problem is at the ESC at least or further upstream.

    Then our new replacement ESCs came in, and we replaced the ESC of the motor that was broken.  On startup... the exact same error still occurs :( So apparently it is not the ESC either.

    However, further upstream from the ESC is just the PDB board, which is only a PWR/GND connection. But that must be connected correctly because the motor does twitch so at least some power is getting in, at least I would think.

    The only other thing I could think of to try was that maybe there was no connectivity on the connection with the White/Red/Black signal connector coming out of the ESC... but I think it would be strange for that to be broken on 2 consecutive ESCs.

    Any suggestions for what I could try next?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
More…