Developer

Copter-3.3 beta testing

Warning #1: an issue has been found with Tower's Pause button which can cause the vehicle to fly to an old position if the vehicle has not sent a position update to Tower in some time.

Warning #2: Copter-3.3.2 fixes a bug found in Copter-3.3.1's desired climb rate initialisation which could lead to a sudden momentary drop when switching from Stabilize or Acro to AltHold, Loiter or PosHold.

Warning #3: Copter-3.3.2 fixes an issue found in Copter-3.3.1 which could lead to hard landings in RTL or AUTO if the WPNAV_SPEED_DN was set too high (i.e. >400 or 4m/s) and/or the WPNAV_ACCEL_Z was set too low (i.e. <100 or 1m/s/s).

Warning #4: a bug was found in Copter-3.3 which could cause a sudden crash if you abort a Take-off initiated from a ground station.  Video description is here.  The bug is fixed in Copter-3.3.1 so we recommend upgrading.

Note #1: AC3.3-rc8 corrected a long standing bug in the HDOP reporting.  HDOP values will appear about 40% lower than previously but this does not actually mean the GPS position is better than before.
Note #2: if upgrading from AC3.2.1 the vehicle's accelerometer calibration needs to be done again.
Note #3: set SERIAL2_PROTOCOL to "3" and reboot the board to enable FrSky telemetry like in previous versions.
Note #4: the wiki will be updated over the next few weeks to explain how to use the new features

Copter-3.3.1 is available through the mission planner.  The full list of changes vs AC3.2.1 can be see in the ReleaseNotes and below are the most recent changes since AC3.3.

Sadly this version (and all future versions) will not run on the APM2.x boards due to CPU speed, flash and RAM restrictions.

Changes from 3.3:

1) Bug fix to prevent potential crash if Follow-Me is used after an aborted takeoff

2) compiler upgraded to 4.9.3 (runs slightly faster than 4.7.2 which was used previously)

Changes from 3.3-rc11:

1) EKF recovers from pre-arm "Compass variance" failure if compasses are consistent

Changes from 3.3-rc10:

1) PreArm "Need 3D Fix" message replaced with detailed reason from EKF

Changes from 3.3-rc9
1) EKF improvements:
    a) simpler optical flow takeoff check
2) Bug Fixes/Minor enhancements:
    a) fix INS3_USE parameter eeprom location
    b) fix SToRM32 serial protocol driver to work with recent versions
    c) increase motor pwm->thrust conversion (aka MOT_THST_EXPO) to 0.65 (was 0.50)
    d) Firmware version sent to GCS in AUTOPILOT_VERSION message
3) Safety:
    a) pre-arm check of compass variance if arming in Loiter, PosHold, Guided
    b) always check GPS before arming in Loiter (previously could be disabled if ARMING_CHECK=0)
    c) sanity check locations received from GCS for follow-me, do-set-home, do-set-ROI
    d) fix optical flow failsafe (was not always triggering LAND when optical flow failed)
    e) failsafe RTL vs LAND decision based on hardcoded 5m from home check (previously used WPNAV_RADIUS parameter)

Thanks for your testing!

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Must have been a poor manufacturing Andy. I have read very good reviews on that module otherwise. People say it gets a 3d fix instantly and report better loitering in forums...

  • I uploaded AC3.4 dev build this morning and gave autotune a 3 axis go.  PID tuning changed quite a bit from 3.3 but results felt very good.  This is on a 550 CF quad with pix, t-motors and Zubax gnss.  The three axis tune took 16 min and was close to battery limit but completed successfully.  Flew an FCF in loiter, alt hold, drift and stab with a couple RTL and land commands thrown in.  I was very impressed with results, copter flew very well, predicable, stable and very responsive with RTL within inches of launch point and relative altitude very close throughout the test.  I don't recommend jumping ahead of betas but it looks to me like you guys have the general flight code about nailed down.  Thanks for all your hard work and dedication, this has been a great enjoyment for me over the last several months and has provided my High School class a tremendous learning opportunity.  

    Cheers,

    RB

  • I have the same message "Error EKF POS VERT AGL"

  • With RC5 I now get the error message "Error EKF POS VERT AGL" all the time.  The quad (550 H Frame) flies fine in loiter, position, stabilize.

    Steve

    • thanks pal for the feedback. It seems that this error does not affect the quad. though when using the Mission Planner, this error prompt is quite annoying :D hopefully this will get fix soon. thanks again!

  • I'm using MP1.3.27 build 1.1.5620.38044 and updated to rc5 and after that I did a "reset to defaults".

    I choosed frame and then I tried to calibrate accel, the program steps from place level to left and then directly to right?
    So I am unable to do the calibration...

    I have uninstalled MP and reinstalled it and the same with the FW but with the same result?

    • I'm getting the same, did you manage to figure out the root cause yet?

      • Seems to be fixed in rc6

    • I tried with 3.2.1 and then the calibration of accel  was OK so it seems to be rc5, rc4 was OK.

  • I'm also using Mission Planner is 1.3.27 build 1.1.5620.38044

    I get EKF PRED POS HORIZ ABS when I power up but changes to "Error EKF POS VERT AGL when i get a satellite lock

    8 satellite hdop 1.8

    I have just flown and everything seems to be working ok, tried loiter but not RTL

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
Joseph Udofia liked Joseph Udofia's profile
Mar 3
More…