Crash on maiden flight- need help

Well, I should have taken the advice of, pretty much everybody, and built a simpler model as my first build. But I didn't... I jumped right in and built a DYS D800 X8, and a Tarot X6 at the same time. I took the D800 X8 out yesterday for her maiden flight.

I really took my time building this thing. I studied everything I could find. I used a Pixhawk, and I very carefully did all of the calibrations, and motor checks in Mission Planner. From my limited experience, it all looked good. Motor numbers, and rotations all look good. I was very careful about installing the props. I'm pretty sure I got all that right.

Here's what happened: I found a great place to maiden flight. Set up everything. radio on. Battery on craft connected. Tower as a GCS. Everything looks good. Good GPS. I armed the craft, and got very nervous, so I disarmed. Did that about 7 times. Finally got up the nerve to go for it. Throttled up, and she rose a bit and immediately did a very fast back filp to the port side and landed about 10 feet away. Some damage, but it can be repaired.

Now I'm trying to figure out what went wrong. I'm a beginner at all this, and reading flight logs. At first glance it looks as though the voltage drops out, and the current spikes as soon as I throttle up. After adding a few more lines to the chart, it looks as though the barometer is going crazy each time I armed/disarmed (when the props spin). The barometer really went crazy on the fateful throttle up.

Could one of you kind folks please take a look at my flight log to help me determine what went wrong and how to fix it? I'm a beginner who took on way too much. However, I am a quick learner. I just need some help. I have attached the log. Any help would be greatly appreciated!

2017-01-18 12-28-14.log

2017-01-18 12-28-14.bin

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hey Justin,

    I finally figured out that the rcou... parameters were actually the motors. Thanks for the graph. Does the voltage/current graph concern you at all? Seems strange that the voltage drops, and current spikes as soon as I throttle up.

    My test today went a bit better. I rigged up a system where I extended the legs horizontally using PVC pipes. I also used a dog leash lawn screw, and some p-cord to keep the copter from lifting more than a foot or so. Impossible for her to flip. OK, this time she lifted level! Problem is, as soon as I throttled up, she went in to battery failsafe/RTL. At that point I lost all throttle control, as, I assume, she was trying to land. She just hug there tugging on the tether. Does it make any sense to you that she might have gotten confused about landing due to the prop wash? I could not throttle down at all. I finally got her to land and disarm by switching the radio off. I have uploaded today's log. Could I bother you to take a look?

    80-01-11_13-55-44.bin

  • I plotted RCIN.C3 (throttle) vs RCOU.C1 through  RCOU.C8 (motors)

    (have a look at attached image, red line is throttle, others are motor outputs)

    Good luck with your test.

    Justin

    graph.JPG

  • Hey Justin, Thank you for taking such a detailed look at my crash. I really appreciate it. Your timing is especially good, as I plan on testing her again on Friday.

    I hear what you are saying about the motor numbers being set up for a DJI. I realized that before finishing the build last time. It was a major pain getting it all right... but I guess that I did not get it right. Strange, but I thought I had it all right after doing the Mission Planner motor testing. I'm new at this, so I must have made an error.

    On this second go-around, I desoldered the esc, and ground wires from the lower board. I then extended each wire and sent the the proper numbered wires directly to Pixhawk (bypassing the pins on the frame). It all checks out in Mission Planner again.

    I have rigged up a set of PVC pipe extenders for the legs, and a tether to the ground, making it impossible for it to flip. I'll check the thrust/roll/pitch/hover with that rig before ever setting her loose again. This has been an expensive learning opportunity. Like I said, I took on way too much for my first build.

    I would like to see the motor information myself. Where do I look in the log?

    Thank again!

    Justin R said:

    ....and while I think of it, ignore the CW / CCW markings on the frame. They are for a DJI flight controller, Pixhawk is different, make sure the motors rotate the way marked in the diagram from my previous message. 

  • ....and while I think of it, ignore the CW / CCW markings on the frame. They are for a DJI flight controller, Pixhawk is different, make sure the motors rotate the way marked in the diagram from my previous message. 

  • Maybe you've already figured this out, but looking at your logs, you only applied a small amount of throttle, and motor 3 went almost to full power.

    This would probably be because the flight controller is trying to level the copter by increasing motor 3 power, motor 3 is connected to the the wrong motor making angle error worse... so it applies yet more power and keeps doing this until it flips.

    I'd be 99% sure this has happened either because the ESCs are connected to the wrong outputs or the flight controller orientation.

    I've just finished a build using this very frame and a Pixhawk, and it was really confusing as the motor test function in mission planner uses letters which don't correlate with the numbers in the APM copter guides, and neither of these match up with the ESC connectors on the frame.

    Use this diagram I made to match up the letters (IGNORE numbers) with the motor test function in mission planner, double check you've mounted the Pixhawk arrow forward and you should be good to go.

    X8 Motoros.jpg

  • Moderator

    While it won't help for this crash it may help to prevent future ones. I do this on all new builds:

    "On shortish grass/lawn, in an open area, in STABILIZE mode (NOT Loiter or PosHold): now carefully throttle up slowly so the multirotor is just starting to "get-light-on-the-skids", DO NOT throttle up so much that it takes off! If it's overpowered or low kv motors/big props this point is maybe at 25% of your throttle stick travel, otherwise normally a bit further up.

    In other words apply just enough power for some lift to be created, but only just.

    Now try to pitch forward gently, starting with 10% stick, you should hear and see the rear motors speed up and the fronts slow down, the craft should also tilt forward slightly.

    Do the same for right roll - gently - right motors slow down, left motors speed up, craft tilts to the right slightly.

    If this doesn't work exactly like this then something is wrong so don't try take off!"

  • My first quad was a f450 every intent for fly this machine I always recorded with my camera his Movements. For all people beginner should record his first flight of his quad. I recomend you read the coments of this post

    http://diydrones.com/group/arducopterusergroup/forum/topics/apm-2-6... 

    Best regards

    fr

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Jetsonhacks: And I helped with the course! JetBot, JetBot, happy little JetBot! JetBot ... GO! Meet the Jetson Specialists Inspiring a…
23 hours ago
DIY Robocars via Twitter
RT @a1k0n: Designed RPi + camera mounts + new bumper for the new car. Fits great on the car first try, except my longest camera cable doesn…
23 hours ago
gotham liked gotham's profile
yesterday
DIY Robocars via Twitter
RT @RoboticMasters: Monaco GP Circuit in the Donkey Sim (coming soon). Including buildings, tunnel and all! https://github.com/robotics-masters/sim-donkeycar-f1/tree/f1-tracks @diyr…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: Here are the details of #AWSDeepRacer finals: https://blog.deepracing.io/2020/12/01/aws-deepracer-league-finals-2020-round-1-schedule/ #awsreinvent2020 #AWSreInvent https://t.co/ovqsjp8V…
Wednesday
DIY Robocars via Twitter
RT @breadcentric: #AWSDeepRacer League #awsreinvent2020 Open race is on Dec 1st - Dec 31st in three categories, 15 DeepRacer Evo (with LIDA…
Wednesday
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars It's just something that's easy to track with chroma keying. I ended up using different colors on th…
Monday
DIY Robocars via Twitter
Monday
DIY Robocars via Twitter
RT @TinkerGen_: "The Tinkergen MARK ($199) is my new favorite starter robocar. It’s got everything — computer vision, deep learning, sensor…
Nov 23
DIY Robocars via Twitter
Nov 23
DIY Robocars via Twitter
RT @roboton_io: Join our FREE Sumo Competition 🤖🏆 👉 https://roboton.io/ranking/vsc2020 #sumo #robot #edtech #competition #games4ed https://t.co/WOx…
Nov 16
DIY Drones via Twitter
First impressions of Tinkergen MARK robocar https://ift.tt/36IeZHc
Nov 16
DIY Robocars via Twitter
Our review of the @TinkerGen_ MARK robocar, which is the best on the market right now https://diyrobocars.com/2020/11/15/first-impressions-of-tinkergen-mark-robocar/ https://t.co/ENIlU5SfZ2
Nov 15
DIY Robocars via Twitter
RT @Ingmar_Stapel: I have now explained the OpenBot project in great detail on my blog with 12 articles step by step. I hope you enjoy read…
Nov 15
DIY Robocars via Twitter
RT @DAVGtech: This is a must attend. Click the link, follow link to read the story, sign up. #chaos2020 #digitalconnection #digitalworld ht…
Nov 15
DIY Robocars via Twitter
RT @a1k0n: Got a new chassis for outdoor races (hobbyking Quantum Vandal) but I totally didn't expect that it might cause problems for my g…
Nov 11
More…