I had everything working and in the tuning phase but something has gone wrong. Even if I put it in STABILIZE while on the ground and move the plane around, roll and pitch are indicated with the attitude indicator but no servos move. I also went into the tuning mode, it shows the pitch and roll servos responding but nothing happens at the servos.  I should also be able to move the sticks while in STABILIZE and have the servos respond to inputs - nothing happens.

FBW_B I should be seeing elevator move down and respond to airspeed but nothing happens - also no servo movement when sticks are moved.

Batteries are good - everything works in manual. I had all defaut PID's saved, reinstalled still nothing. Erased EEPROM reinstalled all sensors work - no output from servos in previously stated modes.

Views: 473

Reply to This

Replies to This Discussion

Hi Clark,

 

Have you tried to reset the board to factory and re-flash the code?

 

Regards

 

Martin.

Yes, do an EEPROM clear and radio setup again and you should be fine.

I have gone through the process twice - clear the EEPROM, re-flash the code, radio setup, mode setup. 

Check it out in STABILIZE_MODE no responce to pitching and rolling the plane and no responce to any of the servos when inputs are made with the radio while in STABILIZE-MODE.

Attitude indicator and airspeed indicator function properly, GPS is working too.

Have you tested in the CLI to check that the output from the IMU is working Clark?

 

Regards

 

Martin

I haven't done it with the CLI, I did put it into tuning mode while I was running in STABILIZE.  While doing that it would show the nav pitch and nav roll, the servo pitch and servo roll did correspond but no servo movement...

Hi Clark,

 

That sounds like the IMU is working, are you in chat now? maybe we could have a few moments ?

 

Martin

Can you post the results of your radio setup? I'd like to see what PWM values were read.

Radio
----------------------------------------
CH1: 1058 | 1467 | 1879
CH2: 1097 | 1628 | 2045
CH3: 1108 | 1500 | 1808
CH4: 1106 | 1517 | 1935
CH5: 1498 | 1500 | 1498
CH6: 1498 | 1500 | 1498
CH7: 1498 | 1500 | 1498
CH8: 963 | 1500 | 2072

 

Here's what I've got

Those look good.

Two questions, just to be clear:

1) with your CLI switch in flight mode and the board restarted and up and running, you get servo output in manual mode but not in other modes?

2) And you've got an ESC plugged into the APM outputs to power the RC rail?

1) Yes, this is what I had going on.

2) Not using an ESC - nitro powered plane using a servo, plugged in 1 2 3 4, 3 being throttle.

 

3) Maybe I should go to bed earlier - after getting home from work reset EEPROM went through all the setups rechecked and setup my pid configuration.

 

EVERYTHING WORKS!!!!!  : )

 

Sorry to waste your time with my late night confusion, still not sure what the problem was.

Thank you for all you help!

Hi, 

I got the some problems like that.

 

how can I clear the eeprom?

 

regards,

Alvaro

Sorry to bother you guys... I just found the way. Thanks.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service