XBee Issues with DIY adaptor problems. I am using a "roll my own version" using the same 900mhz parts as listed in the telemetry kit on DIY drones.  I would have bought the kit is it was available, but well... I went ahead and ordered my xbees from digikey and antenna and adapters from DIY, not realizing the Wiki says use sparkfun or other adapter.  WHY IS THIS?

I followed the instructions to a t, and I had everthing working well and communicating in the planner, and mavlink was connecting with no issues.  After a brief attempt to fly this afternoon while connected to my laptop via xbee, I discnnected my battery and did not disconnect from the planner, which should make no difference.

When I came back inside and tried to connect to my office pc via xbee, mavlink timed out.  I pulled the modules and double checked in x ctu, all settings the same.  The drone side adapter is giving no flashing ambers, solid blue and solid red.  and the diy xbee adapter is getting hot right around the nose of the diy drones stamping.  I attached some photos of the board pulled out of my quad, can anyone help? I know the xbees themselves are right, checked and double checked.  Any help would be greatly appreciated...



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Ian, I Have exactly the same problem as you, I emailed the DIY drones support email and they weren't very helpful, suggesting I replace the custom cable they sell with another one. This is a definite issue. My hunch is a bad batch of USB Xbee boards but I don't know anything for sure

  • I still need community help with thus xbee Xstream bee problem.... I have re flashed the firmware double and triple checked everthing regarding the x bees configuration. I had them working like a dream.  The xbees are flashed with xbp-09 dp 1061.. both modules work just fine connected to the usb.  I even redid the soldering on the ftdi xstream just in case, but no good, nothing gets through when attached to the drone....  I connected via USB, and it did the same reaction.  When I disconnect the battery and remove the abee from the adaptor, the red light doesn't come back on, but still no blinks at all from the amber led.  Switch is on master.  Is there something in apm 2.0 that might cause this "Brick" reaction(it is not bricked as it reads just fne on usb adator, just nothing an ftdi).  Should I call diy support?



This reply was deleted.