Dragonlink v3 Bluetooth connection to Mavutil


Appreciate the help here.  Having quite a bit of trouble attempting to connect Mavlink telemetry over Bluetooth serial.  Someone must to have tried this (run a Mavproxy GCS with the latest Dragonlink).  See all the nitty gritty details here and let me know if you have any experience or suggestions :).  The only reason I link to another forum is because Michael from Dragonlink suggests using that particular forum for help.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hey all, still looking for a solution to this.  I think if you've got any instructions that would help someone connect APM Planner 2 over Bluetooth that would apply to what I'm trying to accomplish.  If you have had success doing this over the Dragonlink V3 bluetooth connection, let me know!  I've since the original post been able to get the Tx to pair fine and get telemetry over a Windows 10 machine without any problems, but in Ubuntu Linux I'm having issues getting the Dragonlink V3 Tx to get assigned as a serial modem to a /dev/<addresss> port to be used.  In Windows the connection with the Dragonlink Bluetooth creates automatically a COM13/14 port to connect with in Mission Planner.  I need to do that in Linux over bluetooth.  See the above RC Groups post for the things I've tried the past couple weeks with no dice. 

This reply was deleted.