Erratic Aileron Output from APM2

Hi Everyone,

Looking for some help troubleshooting my APM2.

I had previously set up the APM2 with my FPV Raptor. Everything had been set up correctly and I had at least 10 successful flights on the plane.

I took the plane out of storage today. I had been sick for the last week or so and hadn't been flying.  The plane was stored in our basement (maybe of importance...)

After taking the plane and FPV equipment out to the flying field, I had connected the battery and immediately noticed that my aileron servos were being driven to one extreme of their travel and held there.  I checked over all my connections and everything seemed solid.  I disconnected the APM from the loop and the receiver would drive the aileron just fine.  So, it  was definitely the APM.  Toggling APM2 state between stabilize and pass-through didn't help, which is concerning.

During all of this, all the other channels are working fine and throws are perfect.  Ailerons do respond a little bit to input from transmitter, so there is still some signal making it through.

I tried a few hard resets and they didn't seem to help.  Checked the connections to the aileron again. Still solid, but still aileron glitching out to extreme throw.  Then one second later it starts working again. APM2 is driving the servo just fine, and transmitter affects the throws.

I do a few more resets and everything is checking out again... so, I stupidly decide to take it up.  Plane makes the launch, climb and about 20 seconds into the flight the ailerons go to extreme again.

Anyone know what might cause this?  I'm going over my connection for the ailerons again, probably going to replace them.  I've checked for shorts on my mounting of the APM2, but the double sided sticky tape I use does not conduct at all (checked with voltmeter).  

I'm wondering if some condensation or humidity may have caused the failure.  Are there any other known cases of this happening?

Luckily, the plane didn't suffer too much damage, so it should fly again.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • My issue ended up being my Spektrum DX6i Transmitter.  The issue I described above occurred on another model, which pretty much confirmed that it was the transmitter.  I checked the Monitor on the outputs and clear as day the Aileron was stuck to one side no matter what input.

    I shipped it back to Horizon and they're servicing it now.  It is possibly related to this potentiometer issue: http://www.spektrumrc.com/Articles/Article.aspx?ArticleID=1885

  • Hi, I think I'm having the same problem here... (and need the same help!)

    Just purchased APM2, trying to install it in my pre built Dynam HawkSky (as a test before transferring into a Skywalker). Just to note that before the APM2, I actually tried the KK Multicopter board with OpenAero and all worked ok.

    With the APM2, looks like the Ailerons are stuck in their extreme position and don't respond to the remote.

    When calibrating the remote through APM Planner, the ailerons stick  as well as the other sticks all respond ok.

    When connecting the aileron straight to the Rx, it works fine.

    But when ailerons are connected through APM, nothing happens really, although as Montana says, you can feel there might be some signal due to small tiny movement when powering the APM up...

    I'm out of solution for that, so any help or even start of an idea would be most welcome :-)

    Could it be an issue with the Arduplane 2.4 just loaded ?

    Could it be an issue with the APM2 itself ?? 

    Could hard reset do the job ? (how to do that?)

    3692456878?profile=original

  • A little more information:

    APM Vesion 2.34

    Receiver: Orange DSM 9 channel with 1 remote.

    ESC: Eflite 30 amp pro with 5.5V Switch-mode BEC, 700mA continuous

     

    Attached is the flight log, but it looks like the servo output for the aileron is not in the log.

    2012-06-24 21-00 120.log

    https://storage.ning.com/topology/rest/1.0/file/get/3692451529?profile=original
This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Wednesday
gotham liked gotham's profile
Dec 3, 2020
More…