Hello guys,

I am trying to get my Arducopter up in the air, but it seems to get more complex than I thought. 

I followed all the instructions to build and calibrate it as on the google wiki. However I am facing great trouble getting the ESC calibrated. I setup the radio just fine. Then go onto calibrate the ESC and it gives me the first two beeps. Then when I lower the throttle on my radio it does not give me the final beep. My battery is connected and so is the four wire connector to APM. I have a feeling there is something wrong with the ESC. I have been unable to get my motors spinning. Please advise!


Views: 3924

Reply to This

Replies to This Discussion

Also I use the 'motors' command in setup and my CLI does not give me any response. I saw from Jani's Youtube video, that it should at least say 'Press Enter to cancel'.... I got this to appear in radio calibration however.. 

Try a manual calibration of your ESCs. Unplug any ESC from the PDB; disconnect power. remove any props.

Plug the ESC into channel three of the receiver. Raise the throttle to max, and apply power to the ESC in use (only). Wait for it to make noise, twice, then lower the throttle. Repeat for each ESC.


As for motor spinning, do you know all the commands to arm/autotrim/relevel/disarm your motors?

If not, then you will want to become acquainted with these tx-based commands.

Ahh I ll try the manual calibrations.. 

Also I am not sure what the Tx commands are for dis/arming the motors. I use a FlySky FS-CT6B. I am really new to aerial vehicles.

Thanks for the help!


I suspected you did not know about the dis/arming. They are in the manual, please read it carefully, all the way through, from start to finish. 


Here are your crib notes (but no cheating! RTFM please!)


yaw hard right - arm motors (wait for the green LED to go solid)

yaw hard left - disarm motors/save eeprom (blinking LEDs, do this *before* you approach the AC!)

yaw hard right 20 seconds - set auto trim for 45 seconds, arm motors

yaw lard left 15 seconds - relevel AC, disarm motors


Respect the props! Disarm your motors, or you will spend time in the ER having your fingers/hands sewn back together! There are plenty of photos and stories of members here and in RC groups who knew better, and made a mistake. They share their mistakes and pain in hopes that it will save you the same.


Before you fly, you should know not only about these arming commands, but also about hand tests, tethered flight tests, leveling, verifying motor and prop direction, verifying ESC connections, and you should read over all the troubleshooting tips. Develop a pre-flight checklist. You should understand lipo management, and keep your early flights short. And in case I forgot to mention it, RTFM. :)

Sure.. That makes sense I ll go over that part right now. Thanks for the great tips!

In the meantime I tried the manual calibration of the ESCs. So I follow all the instructions as listed. Then I plus in the Lipo to my ESC through the power board. I hear the ESC beeping. The pitch is much lower than what it was during auto-calibration. However when I pull down the throttle, I do not hear any beep. The only thing interesting was that it emits a beeping sound when I disconnect the Lipo again. What do I do?

Refer to the documentation that shipped with your ESC. The beep codes for ESCs are specific to the product, as are the programming steps. Each ESC will include instructions detailing the programming, calibration, beep codes, and error or LED codes. The manual discusses the procedure for jDrones-style ESCs. 

I know quite a few CMU alumni, so I'm going to guess that you have already tried to put this quad into flight, but it did not go as well as you expected, and so you backed off to the ESC. Perhaps you first tried to give it throttle, but without knowing how to arm/disarm, it did not fly. Now that you know how, you have tried ESC calibration again, then armed, and tried to lift off, but it did not pop up and hover, so something must be wrong, yes?


If this is the case, let me know, and we can work on the next issue. ESC calibration is more or less straight forward for most ESCs. It is possible that you might not be waiting long enough at high throttle, or that your servo cable is reversed (unlikely) but I would bet that if you did the described procedure, given 90% of all ESCs, it will be calibrated already. And, like 99% of all first time ArduCopter fliers, even a CMU student, you will have expectations for what it will do in the first flight tests, which are far too optimistic. This is especially true if you have not read the manual cover to cover at least three times ;)


There are many, many things that are likely to be wrong in your first flight tests. In fact, the more so because you are a CMU student, if you are a typical CMU student, to whom so many complex tasks have come easy most of your life. There are some troublesome details, so many little things that can easily be wrong, and even if they are all right, you might not recognize a "good" result for a first time flight test. Kindly yours, and here to help...

I think you got it about right in the first half. I kind of rushed into building it and wanted to get it up as soon as I could. I dont have the ESC manual on me at the moment and dont find it online either. I can possibly hunt it down when I get home from the lab.

In any case, its the standard jDrones 20 Amp ESC. What would you suggest I do?

My lack of experience with electronics given a CS background does not help either.

Thank you!

Using the manual method, disconnect power, connect each ESC to channel three on the RX, in turn, put the throttle to high on the TX, make sure it is turned on, make sure there is no prop on the motor, then apply power to the ESC. Then just wait a while for it to beep. And wait some more. A common mistake is not waiting long enough. You can always re-do it if you "waited too long." Then pull the throttle low, and do the rest of the ESCs the same way. 


Chances are, your ESC calibration is just fine. And it does not hurt to calibrate them twice anyways. 


You will have many other challenges; in all likelihood, whatever issues you encounter after this will not be related to ESCs not being calibrated. 


Now, what did it do when you tried to fly it? One arm came up, and it was off level, and it tried to flip before you got it into the air?

just to add on Mike's note.. do no forget to pull down throttle stick to lowest level before rudder inputs. if still not work, reduce throttle trim to lowest.. just my 2 cents

Nubli, that is a great tip, one I had not even considered mentioning.


Make sure all the trim settings on your TX, in particular, the slider just to the right of the left throttle stick (on your radio) are set to their center position. Generally speaking, you will not use trim on the transmitter (and never, never, never use trim on yaw with ArduCopter, even if you decide to ignore this rule for the others)



Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service