We are building a new quadcopter, the relevant parts for the problem are listed bellow:

Motors: Tmotor U3 

ESC: Tmotor Air 40A (no BEC, 600Hz)


FC: Pixhawk 3DR

TX/RX: Futaba 10J / Futuba 2008SB, connected in SBUS

EDIT: Firmware(s) tested: 3.2 & 3.2.1

Note: We have had the Pixhawk since the end of 2013 and flew it very successfully before on another RIG.

The problem is quite simple, we mounted motors and ESC, we made the ESC calibration using a squid cable connected to the RX throttle. Up to here, no problems, motors are in sync and all rotating in the good direction.

Then we connect them to the Pixhawk, after some basic config we intend to arm to check the correct working of the motors. Only 2 ESC are initialized when arming, so only 2 motors run. It doesn't really matter which ones, as if we change the order of the ESC pins on the Pixhalk, other 2 ESC got activated and spin their motors. We've been testing different RC_FREQ without success. To describe the problem exaustively, we should add that sometimes, 3 ESC (randomly, or so it seems) are initialized, yet one of them quicky un-init before we can arm.


- We've read somewhere (on this forum) that the PWM output of the Pixhawk are 3.3v instead of 5V, could this be the problem?

- Is it because our Pixhawk has an older revision (We don't really know which one btw) ?

- Did anybody reading this got this combination of FC/ESC to run?

- If not, should an incompatibility be listed?

Anyone with a beginning of an answer would help big deal!

Thanks a lot for reading.

Best regards,


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello
    we have a similar problem, can move a motor with their respective esc from a PWM input, but when I connect the 4 motors to pixhawk, for some strange reason one engine does not work, was a esc yesterday, today was another esc who does not work, please talves can guide us, or share with us, something to know what happened, thanks.
    • Hello,

      At the end, we connected the all 4 esc on another FC and confirmed the problem comes from the pixhawk. I guess we will buy another FC. I filed a support ticket to 3dr without any answer, this is sad.

      Crossing message on the the forum I find out an old revision was using less Voltage on the Pwm causing some ESC not to work. That is the revision we seem to have. There we stand...

      I suggest you to get an Xaicraft miniX, it'll do the job.



  • Does anybody have any idea on this topic? Is my pixhawk damaged or those ESC simply don't work with it?

    • They should work fine together. I use the Tmotor Air 40A ESC with Tmotor 580kv motors and a Pixhawk FC. I used the all-at-once ESC calibration method listed on the Ardupilot wiki page. http://copter.ardupilot.com/wiki/initial-setup/esc-motor/

      I believe I had to mess around with the Throttle PWM values in order to arm the copter but I can't remember. I'll be sure to check my values when I get a chance.


      • Thank you for your reply Chris.

        I also tried to use the Pixhawk all-at-once calibration, but only 2 out of the 4 esc starts the calibration process.

        It's pretty much following the same pattern as when I use the switch to unlock the quad, it only initialise 2 out of 4 ESC


        • hmmm...thats pretty interesting. Maybe you could flash your pixhawk with the latest stable version of arducopter and start from scratch. I would also check the continuity of each of your solder joints. Also check your RC_3 MIN and MAX PWM values after you've done your radio calibration. If the MIN value is too high or low then the ESC's won't arm. 

          So each ESC continuously beeps at 1 second intervals until you arm the safety switch and then only two will arm and the others continue to beep or they all stop beeping but two motors won't spin up?  

          • So each ESC continuously beeps at 1 second intervals until you arm the safety switch and then only two will arm and the others continue to beep or they all stop beeping but two motors won't spin up?  


             Also check your RC_3 MIN and MAX PWM values after you've done your radio calibration. If the MIN value is too high or low then the ESC's won't arm. 

            You got something here. It can pretty much be that considering I've never used the Pixhawk with this RX/TX. The throttle min can be too low. I'll check that and let you know.

            Thank you very much!


            • Sorry, misread the 1st part:

              So each ESC continuously beeps at 1 second intervals until you arm the safety switch and then only two will arm and the others continue to beep. <= Yes. 

              2 ESC just continu to bip like I didn't activate the switch.

              • According to the Air 40A ESC manual, those other two aren't receiving a output signal from the throttle channel from the receiver. So it might actually be a ESC calibration issue. I don't have much experience with Futaba products so I don't know if I can be much help if you're having receiver issues. Just that Sbus needs to be plugged into RC IN on the Pixhawk and not the Sbus port. Btw the RC IN port can only power a receiver, don't ever try to power anything through your receiver i.e. servo retracts. It will cause the pixhawk to reboot since it can only output enough current to power the receiver. I learned this the hard way and had a bad crash awhile back.

                • I'm off the office for a few days, so I can't test for now. But i'm pretty confident you put me on a track with the low PWM throttle. Out of pure memory, I think my lower throttle pwm was around 975. I found it strange while setting up the failsafe, but that didn't ring a bell until I saw your post. It should more reasonnably be on the 1000-1100 range.

                  About the ESC calibration, I calibrated them using a squid cable plugged on the throttle of the reciever (so by-passing completetly the FC) and get them all to work perfectly, I calibrated both timing and throttle range successfully.

                  I do have the RX connected to the RC port of the pixhalk, and I won't intend to power anything else than the RX through this port :)

                  For the complete story, we bought the Pixhawk 2 years ago trying to find a viable alternative to our Naza M v2 and Naza light, which both were very consistent at crashing our drone or flying away. At first we found the PX crasily complicated and quite quickly got a superX from Xaircraft instead which we still fly on our main drone today (amazing FC). In the meanwhile we bought some little hobby quad to play with and as I mounted the PX on mine I got the learn to make it work and after some try & fail & refining, got it to work with the very same amazing consistency than the superX (there was no autotune back then, now it's all very easy to get it working smoothly). 

                  So back to present, we are mounting our 2nd "pro" multicopter and though the PX would do the job just fine up to here :)

                  I'm pretty confident that this baby will fly soon!


This reply was deleted.


DIY Robocars via Twitter
Videos from the ICRA autonomous racing workshop are now available: https://linklab-uva.github.io/icra-autonomous-racing/
DIY Robocars via Twitter
RT @SmallpixelCar: Prepared race track for Warm Spring Raceways @wsraceways and looking forward to test my new car at RAMS RC @ramsaicar fa…
Jun 6
DIY Robocars via Twitter
RT @f1tenth: Trying out some nasty blocking maneuvers 🏎️🤖 #f1tenth #autonomousracing https://t.co/nMTstsaogM
Jun 5
DIY Robocars via Twitter
May 27
DIY Robocars via Twitter
RT @araffin2: I will talk this Saturday from 18:00 to 19:00 Paris time for the @diyrobocars community about learning to race in hours using…
May 27
DIY Robocars via Twitter
RT @a1k0n: Luckily the infeasible hairpin problem was easily reproducible in simulation and I could test the fix before bringing the car ba…
May 26
DIY Robocars via Twitter
RT @a1k0n: Another problem was that I was over-constraining the car's allowed accelerations, so it didn't think it could turn as tight as i…
May 26
DIY Robocars via Twitter
RT @a1k0n: Breaking the map up into two halves worked, but I had to be more careful about separating the inner track from outer. There's se…
May 26
DIY Robocars via Twitter
RT @a1k0n: Here's a datalog for my fastest lap of the day. Lap timer is tiny window lower-left. https://t.co/myrlWWrKUY
May 26
DIY Robocars via Twitter
May 26
DIY Robocars via Twitter
RT @a1k0n: Here was my car's POV. Man this track is confusing in first-person! After the incident my camera was all scuffed up and I was af…
May 23
DIY Robocars via Twitter
RT @circuitlaunch: Loved seeing so many familiar (masked) faces at Circuit Launch today for our first in person @diyrobocars in over a year…
May 22
DIY Robocars via Twitter
RT @circuitlaunch: Last but not least, mystery guest @BostonDynamics Spot took to the track @diyrobocars He enjoyed the #brazilianbbq too 😂…
May 22
DIY Robocars via Twitter
RT @SmallpixelCar: Today’s race @circuitlaunch for @diyrobocars with @a1k0n Was busy in the morning and did not get a chance to tune camera…
May 22
DIY Robocars via Twitter
RT @a1k0n: This was epic. My car was barely working this morning, had to make a lot of changes and extremely dirty hacks. Post-race analysi…
May 22
DIY Robocars via Twitter
DIY Robocars @ Circuit Launch, 3/7/2020 https://twitch.tv/diyrobocars
May 22