I just ran into some troubles trying to get my fixed-wing aircraft to work again.

After I had a failure of my rudder during flight I tried to figure out why and then none of my servos responded anymore (lukily on groud allready).

I'm using a PX4 with the Ardupilot Plane-firmware 3.7.0.

I have a single motor with a MULTIPLEX BL-20 SD-L (ESC).

The Problem I am having is as follows:

When powering the Pixhawk the ESC starts beeping periodicly. When pressing the safetyswitch I get a faster beeping (~5 beeps/sec). I then have no control over the servos or the motor via RC (cannot arm it). Even without arming I should be able to at least get a reaction from the servos.

What I have tried during my 2 weeks of total frustration with this problem:

-radiocalibration (~thousend times)

-checked all components of my assembly for any kind of error

-bought a new Pixhawk

-bought a new ESC

-calibrated the ESC manualy (using the RC and the reciver with the ESC connected without the PX4)

-much more things which I allready forgot

To me it seems finally like the ESC is not calibrated properly. The instruction of the ESC says, that the beeping meens the ESC is not gettin a 0 throttle signal.

To calibrate the ESC with the PX4 I tried to do so with a quadcopter-firmware uploaded onto PX4.

This failed probably since its a wrong type of ESC for multimotor aircrafts.

Does someone know how to calibrate the ESC on with PX4 and the plane-firmware ?

Does someone have a  solution to the problem!? I would prefer an comprehensible one but after 2 weeks I would take a magical solution as well!

Did someone have this problem allready? I didn't find it in the other topics.

I hope for a hint and thank you in advance!

All the best,


Views: 133

Reply to This

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service