Hey guys, I cannot find a detailed guide on getting the EZUHF and the APM2.5 to play nice. I have several specific questions.

1. Must I provide two seperate power sources to the APM2.5 board, one on input and one on output pins? Does the answer to this change under any conditions?

2. Has anyone successfully gotten the APM2.5 and EZUHF to work together? If so, what physical configuration did you go with? PPM or PWM?

3. Is there a voltage step up or regulator needed because of the voltage difference between the units? does this change if PWM set up is possible?

4. Do you have any pictures of the setup that works? 

My goal is to use the apm in a Penguin FPV plane. I have a long range set up now...just trying to get the apm to work with EZ gear! Thanks!

Views: 3019

Attachments:

Reply to This

Replies to This Discussion

1 no

2 yes, ppm

3 no

4 not me but read both manuals and you should be fine.

Can you just wire it up traditionally? In other words, channel 1 to 1 and so on? with the APM2.5 in the middle? or does it require the sum signal set up?

any luck, can you help me, i have the same problem.

regards

Why not use PPM? Otherwise just wire up 1 for one input. Better n safer if u remove JP1 n power input n output separately. See RCGroups RCTimer thread P1.

i was talking about the problem? Has anyone successfully gotten the APM2.5 and EZUHF to work together? If so, what physical configuration did you go with? PPM or PWM?

the rempote is turnagy 9x

Regards

Yes, I have it working on both Futaba 10CAG and T9x. I use PPM, less wires. Either method will work. Sorry, I may be missing your point though.

Regards,

Steven

Can you give some comments on how you did this ?

I have tried hooking up all 8 signal wires from the EZUHF -> APM, but the APM channel inputs twitch and jump between the true position and center.

I tried setting rx output =muxed on rx1 (under the config tool sero mapping tab) and adding a jumper between signals 2 and 3 but the APM sees no input. All channels inputs are set to max. Moving the sticks and nobs makes no difference they are not seen.

I know my rx and tx are communicating because if i connect the rx via usb to my computer, i can see the correct values for each radio channel, eg moving sticks around also moves the corresponding channel numeric value.

Just a note in case it might help anyone else in the future. If stuff doesnt work, reflash everything but do not "preserve" the old config using the config tool. I rebinded and everything now works. I have it working without muxing and am simply connecting the signal wires from the ezuhf rx to the apm using individual wires. The benefit of this is i can easily swap and remap channels without updating the servo mappings on the rx. This makes it easy to rip out the ezuhf from copter to plane.

Thanks for Updating!

Im just about to try the same!Can you upload a picture? When you say:

"Simply connecting the signal wires from the ezuhf rx to the apm using individual wires"

You have a jumper on 2/3 still? What firmware version you running on the EzUHF?

My ezuhf has the latest firmware which i installed about a month ago. 

I dont have a cable shorting pins 2 and 3 on the APM so it enters PWM(???) (the one where all channels are muxed on the one channel) mode. In the ezuhf rx mapping all channels simply map one by one, except for one which carries the link quality to i think channel 7. I then got minimosd-extra and hacked the source a bit so it the rssi is read from the same channel 7. I think the latest minimosd-extra has this ability built in and configurable using the ctool.

I connect pin by pin. See the pic above for clarification. This makes it easier to route channels by simply swapping cables.

I use these cables, you can get them in varying lengths.

http://www.ebay.com.au/itm/161114477181?ssPageName=STRK:MEWNX:IT&am...

The cables are not silicon but plastic, shouldnt really be a problem for low power stuff like signals.

My pic is a bit confusing because i didnt use the rainbow wiring so you cant simply follow some colour to see each end. Might fix when i get some time.

As a note i also flashed the PPM decoding chip on the APM just to be safe. There was a notice that older APMs before March or April 2013 did not have the latest and greatest f/w and this might cause problems.

Thanks!

I haven't got the cables yet so i just connected 1 -1 with normal 3 core servo cables and works a treat!

I will order the cables though as its less wres to mess with! Thanks for uploading the photo!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service