Failed to Boot MPU6000

My 3DR APM2.5+ was working fine with 2.91.

So i decided to upgrade to 3.0.1 then the "fun" started.

I was able to upgrade however I had to do the compassmot calibration

Shortly after I could not connect to the apm, it would freeze at the
"Get param" stage 67 out of 296 i think. Connection is via usb. I tried changing
serial port with the same result.

I can load firmwares okay from Mission Planner still. I tried going back to the previous
version with the same reults.

I can also connect via Terminal however when I try to do the

test> imu I get "Failed to boot MPU6000 5 times" then

PANIC: failed to boot MPU6000 5 times.

This is so strange since the apm was working fine before!

Any suggestions ? Thank you

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I know this is an old post but it might help others who are researching this problem...

    I have the exact same issue with one of my APM 2.5 boards. Turns out the 3.3vdc regulator went out. The tolerance is 3.3 +- 5% and mine is reading 2.99. Replaced the regulator and problem solved.

  • I'm having the same issues described. Any solution?

  • Update: Reading through the manual for the "ABC" leds , I notice that the "A" red light on my unit flashes slowly.

    Shouldn't this be solid after a while ?

  • Well had another go, downloaded mission planner 1.2.48 and loaded firmware 2.9.1. I was able to connect to the apm in mission planner and also no errors in terminal during the tests of IMU . Very strange .
  • Have you tried deleting the resetting the apm and deleting the firmware before upgrading or downgrading?

  • Moderator

    Sounds like board failure:

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21