Failed to update home location (1)

Hi,

We are writing a UAV simulator that talks the MAVLink protocol, and we have been using it successfully with QGroundControl. We've tried using it with Mission Planner too, and although for the most part it works, there are still a few problems we are trying to figure out. The one I'm having hard time with is this: we connect to our simulator using UDP just fine, but after about 10 sec, the Mission Planner shows a dialog box "Failed to update home location (1)". We do not see a MAV_CMD_DO_SET_HOME or MAV_CMD_GET_HOME_POSITION coming from the Mission Planner, and we tried sending out HOME_POSITION message to the MP when we first connect, but that didn't help. Any ideas what MAVLink message(s) we need to send out to stop this message from popping out?

Thanks,

Paul

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    do you implement the waypoint protocol?

    mp trys to pull waypoint 0 on arming.

    • Michael, thank you so much for the prompt reply! Yes, that was it! We implement the waypoint protocol, but we never set waypoint 0 as the home location, as QGroundControl didn't seem to require it. Once we set waypoint 0 to home on arming, everything worked fine. Thanks again!

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…