Hello guys, i crashed my hexacopter one week ago, so i decided to take it appart and use what is left to build a quadcoptere with the same components; same flight controller (pixhawk), same motors (620kv), same ESC ( hobbywing 40A) and same transmitter and receiver. However, when done, i found that the motors keeps beeping ( a single beep every second) even after arming. I cant do an esc calibration (when it goes into calibration mode, the motors keep beeping and do not count the number of lipo cells). No fault is being displaced on mission planner nor on the pixhawk light, and everything looks normal. I tried to calibrate each esc alone directly from the receiver, they all worked normally and the motors spin, but when connected to pixhawk the same problem appears even after pushing the safety switch, they keep beeping!!! I tried to reset and format the pixhawk, insalled arduplane then arducopter again, it didnt work.i literaly tried eveything with no success. Im assuming the pixhawk is damaged. Please can anyone help me, before i buy a new flight controller.
Thank you so much.

Views: 22

Reply to This

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service