figuring out the Antenna Tracker

3691139590?profile=originalNot many people know but we have an piece of open source software for controlling an Antenna Tracker.  It's been built by Tridge (Arduplane lead developer) for use in the outback challenge.

Sadly we have no documentation and, as far as I know, nobody except Tridge has used it.  Still given Tridge's track record on building great software I suspect it works well and if it doesn't, I'm sure we can fix it.  So to not let this piece of code go to waste, I'd like some help from people who are interested to give it a try and help me figure out how it works.

Here's the little that I know:

  • It runs on any of our supported board (APM1, APM2, PX4, Pixhawk, Flymaple and perhaps VRBrain)
  • For APM1/APM2 users building the code is as easy as opening our hacked ArduinoIDE and selecting File > SketchBook > Tools > AntennaTracker and then building in the normal way.  For PX4/Pixhawk, our autobuilder doesn't automatically build a binary but I can provide one if people are interested.
  • It can control a Pan and Tilt gimbal like this or this found on
  • It may or may not require a GPS
  • It must somehow receive vehicle position updates from the ground station which has the telemetry radio that is connected to the vehicle. Maybe through a USB cable.  Tridge probably uses the python ground station, MAVProxy, to passthrough the vehicle position data to the AT but perhaps we can get MichaelO to build out a similar feature in Mission Planner.
  • I imagine this antenna tracker could also be used to keep a camera focused on the vehicle which might be good for easing the burden on creating videos of our vehicles.

So if you want to give it a try please do and stick any findings, questions or issues below. Alternatively Issues can go into the issues list.

I'll start sticking things into the wiki as they become clear.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • MR60

    Hey guys, Randy,

    I tested the latest antenna tracker version (V1) a few days ago. I first tried in baro mode and I get large pointing errors both in pitch and yaw, as shown in the video below. In GPS mode it appears there is a bit "more pointing recision" but the tracker is still not perfectly pointing to the copter, with deviation that can get to more than 10 degrees. The poiting error is not constant and I believe it is not due to the mechanical setup of the tracker itself.

    I also join the log file for troubleshooting,

    log file to download (available for a week max) :

    Video showing the behaviour:

  • Randy, I know hobby use is not a priority, but still, never hurts to aks: 

    us fpv hobby flyers do not need a full bidirectional mavlink with our vehicles, but we would surely do like to use antenna trackers. 

    I know AP sends frsky telemetry quite nicely, however, antenna tracker can't use it. It would be beneficial for FPV crowd if ATT would also take in frsky telemetry to lock position. it doesn't need to be inverted either. 

  • Yes, I am using too, because I thougt the pitch range setting might already be in the GUI. I am on vacation right now, so I can not test anything. I just wanted to confirm that I had some of the issues, too. I first thought the wifi connection might be the problem, but SSH etc is not affected.

  • I'm on 1.3.39. We're using the system a lot and I cannot take a risk with beta versions.
  • Developer


    Can you confirm which version of Mission Planner you're using?  I'm on (it's the beta version of MP).

  • I am running1.0 on a RPi3/Navio+. I connect to MP via wifi and I can confirm that parameter download is really slow. It starts fast for the first few params then it slows down. I also get the "failed to update home position" in different intervals. During testing I noticed, that MP does not get any data from the tracker shortly before the error message appears. After clicking the message away, everything works again, till the next message.

    The reverse checkboxes in MP do not work. I had to set servo direction in the full parameter list. 

  • By the way, don't wait longer before doing the release. I test when a release comes out, I don't test beta stuff... I think it was perfectly ok to do the release. I hope you can find what went wrong.
  • Randy,

    The point is that with 0.8, all is working perfectly. So I guess all my settings should be ok. When I installed 1.0, I didn't touch or change anything. Or is there a difference between 0.8 and 1.0?

    I double checked, it is as you mention. Slider left, he turn ccw, right cw.
  • Developer


    Thanks for the logs.  Can you confirm that the yaw servos reverse checkbox is set correctly?  On the latest beta mission planner (i'm unsure about the latest official mission planner) there is a reverse checkbox on the extended tuning screen, a slider and a test button (I'm pretty sure you've already seen these).  When you move the slider and push test the tracker should move in the same direction as the slider.

    • put the slider all the way to the left and push the test button (sometimes you need to push it several times) and the antenna should rotate to the left (i.e. counter-clockwise)
    • put the slider all the way to the right and push the test button - the tracker should rotate to the right (i.e. clockwise).
    • if it doesn't move in the correct direction, click the reverse checkbox and try again.

    It's very possible though that a bug has been introduced in the handling of continuous rotation servos because I see this is what you're using for your yaw servo.  I don't have one of these so it's difficult to test.

    I guess next time I'll wait longer before doing the release!

  • Hi Randy,

    I uploaded all my logs from the 15th, where I started testing version 1.0 and changed back to 0.8. Not sure which logs has what info, so I dumped them all here:

    Hope it helps.

    Randy said:


    If you've got a lot that would be great.  It's really total guess work without a log I'm afraid.

This reply was deleted.