First build tricopter keep spinning problem

My controller is APM 2.6
Frame I used :
Motor I used :
ESC I used :
Servo I used :

according to this instruction

I install the propeller exactly same as the instruction

motor Setting 1 :
Motor Setting 2 :

but no matter which motor setting i use , the tircopter just keep spining at the middle of the air when take off (i didnt touch any stick but only rsie up the Thorttle stick) , it suppose just take off and hold right ?
whats wrong with my tricopter ?

Here is my servo control ... it should be correct  let me know if it is abnormal ....

guys please help !!! 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • hi guys, please how did you solve this issue eventually? I'm currently trying to fly a tricopter using Pixhawk. The frame is the minitricopter frame from RCexplorer and as soon as I arm the drone, and raise the throttle to lifting height, it begins to spin around the yaw axis in the counter clockwise direction.

    I have reversed the servo channel via the RC4_REV parameter as the servo is connected via the main4 output as per Pixhawk documentation. Still no change.

    I don't know if its the pID gains, as i've not really tuned them, its just the default ones but the docs did say that should at least hover.

  • Hi! James is right. I was having the same problem, then I reversed the yaw direction and worked! But I use Multiwii, but I'm sure is almost the same on ardupilot. Good look.
    • Ya i am think without this reversed Yaw direction ....the tricopter will similar to a broken 1 arm quadcopter it keep spining 

  • Hi David,

    I have no experience with tricopters but I suspect that the APM is using the inverse signal to correct (i.e it is telling the yaw servo to move in the wrong direction). I had a quick search and could not find much reference to any modern version of Arducopter to help. Possibly setting RC4_REV to -1 would do the trick but I think you would also have to reverse the direction of this channel on your transmitter too as it is currently moving the servo in the correct direction. Hopefully someone with a tricopter will chime in....

    • Looks like that should be RC7_REV and not RC4_REV (the output channel connected to your YAW servo in any case!)

      • Hey James !

        I changed the RC7_REV to -1 it really fixed the spining problem !!

        however when i take off to try i found another thing i may need to reverse , cause when i push forward the elevator stick ,the copter suppose go forward but now go backward instead and i push backward it goes any setting i need to change to fix this ?

        well....somehow i feel ppl in this forum is much knowledgeable then 3DR tech just one message and tell me the answer... i send the same video same message to them , back and for so many email and end up i got "i am not really sure whats going on, but it does look odd..." LOL  and ask me to send them my log file ...

        anyways thx for your help first !

        • Hi David,

          I am glad I could help!

          If the copter is hovering just fine in stabilize but responding incorrectly to your input, then you should just reverse the pitch channel on your transmitter.



          • thats simple ! I tired ! Fixed !!!

            i just have few second test fly indoor at home , and looks ok , at least takeoffable and controllable lol

            will have some fly this weekend !! 

            Thank you soooo much !! this is my first build copter and first build tricopter as well ...ppl said i give myself a hard project for the very first DIY copter ....lucky that i have dude !! thx you guys so much !! 

This reply was deleted.