Hi,

I am having problems arming my quad. I am using APM planner with a Turnigy transmitter with er9X firmware installed. I reset the ESEs and all of the motors powered up. I can configure and save but I cannot arm the copter have used throttle down and direction to the right for 5-8 seconds with no reaction from the copter which has red arming led flashing. On the flight data tab I am getting telemetry and the compass is responsive. Thanks for any help.

Views: 271

Attachments:

Reply to This

Replies to This Discussion

Perhaps your one channel is reversed. Try reversing pitch channel on your transmitter and try again. 

Also (not that this will affect arming in any way) by looking at the attached picture, I can see that you have not calibrated channels 5 to 8. You will need to at least connect, assign and calibrate channel 5 since that is used for flight modes . 

what flight controller are you using? 

Where do you assign channels 5 to 8?

APM 2.5

are you using a mode 2 transmitter? I assume so if you are trying to arm by pulling down on the throttle and pressing to the right. when you load up Mission planner & are in radio calibration (like image above) when you move the Yaw, (left stick) to the right or left,

does the yaw on screen move to the left and right respectively?

if its not moving left when your pressing left, it could be you need to reverse the yaw channel,

have you tried to arm the quad by holding throttle down to left?

on my APM 2.6 I yaw right and down, for a few seconds, the led's blink then i will repeat the down to the right once again, and the lights stop blinking, leaving only the solid red led (armed) 

You really need to read the Manual / Wiki. Not doing so will cause major issues going forward. 

http://copter.ardupilot.com/wiki/introduction/

Kind regards 

Might be a pointless question but do you use dual rates on your rudder channel? If you calibrate the radio using high rates you can only arm using high rates.

Have you tried arming while on the flight data screen (1st screen on mission planner dont know if its the same on apm planner) as usually it will say why it can't arm on the hud in the top left corner.

I also just need to mention that Transmitter trims need to be centered. If not the arming might not work .

My first suggestion stands though ... Make sure the channel is not reversed. On the Spectrum, the pitch needs to be reversed otherwise it does not go in the correct direction on the APM. 

Make sure you are trying to arm in stabilized mode.

Yes I have a mode 2 transmitter and yes my controls mirror what I am seeing on the radio calibration screen. On the flight data screen of APM planner there is an arm button which also does nothing. Sorry for my lack of knowledge with remote control as this is my first build. I have tried throttle down with yaw to both right and left and I am getting nothing. @MarkM nothing is showing up in the HUD when I try to arm with the transmitter or the ARM button on the flight data screen. And the quad is being armed in stabilized mode. I am getting pretty frustrated and I am not sure what to do. Thanks for everyone's help.

d

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service