I tried all the eight debugging steps, but the error persists.

My arduino board works perfectly with the latest FTDI drive, but with DIY FTDI cable I have this error:



So I will try to use an Usbasp AVR programmer to replace the bootloader with AVRDude.
It will require a "path-board" between programer and ArduIMU, because the pins order is different. But the worse part is the pin "D10"... what is it funcion?

On AVR programer I have this pins:

MOSI
VCC
RST
SCK
MISO
GND

On the ArduIMU+ there is:

GND
VCC
SCK
MISO
MOSI
D10     <---- ( what is this??? Is it mandatory for the connection with ArduIMU+?)
RST

Last question: Is the bootloader exactly the same that Arduino 328?

My spine is freezing... but I don't see another way to go.

------------------------------------------------------------------------------
Added:

SOLVED

It was solved by doing this steps over an AVR programmer.
(Is VERY important that you do the first step and check the result)

1 - Erasing the chip (make sure that "lock fuses" are changed to FF);
2 - Setting the other fuses by this way:

low_fuses = 0xFF (bits 11111111)
high_fuses = 0xDA (bits 11011010)
extended_fuses = 0x05 (bits xxxxx101, because only the three last bits are changeable) ;

3 - Recording the "ATmegaBOOT_168_atmega328.hex".


Views: 2527

Reply to This

Replies to This Discussion

D10 acumula slave-select. se não tiver mais nada no barramento, jumpeia.
esr
Opa! Então, Ernani... Posso deixar esse pino "D10" de fora ou tenho que aterrar?
Não entendi bem a parte do "slave-select"...


Hey! So, Ernani... Can I leave out the "D10" pin or I need to put it on ground?
I don't understand completely the "slave-select" part...
cara, quando chegar em casa vejo no datasheet e posto de novo. é o pino que seleciona o nó como slave ativo
I'm not sure I understand. You're using the DIY Drones FTDI cable, right? The bootloader is exactly the same as the one on any Arduino (or ArduPilot). But if you're going to replace the booloader with and AVR programmer, the ISCP header is also totally standard. Just like any Arduino board.
OK, Ernani. Obrigado pela força! :)

Chris,

Yes. I'm using the DIY Drones FTDI cable. But, no matter what I do... isn't working.

I will try to replace the bootloader, because I tried everything else. It's seems to be like you said on your debugging tutorial: It's rare, but maybe that the bootloader is corrupted.

The header that comes with my AVR programmer is for proto-board jobs. So, I have done a lot of things with ATMega chips on proto-boards, but I never used it on my Seeeduino 328. Because of it, I don't now what I need to do with the "D10" on ArduIMU. I never used another pins for programming that aren't in my programmer:

I burned the bootloader with the AVR Programmer, but it wasn't the problem. The red error output wasn't solved.

If anyone have the USBasp programmer and want to burn bootloader using the Arduino IDE. All you need to do is add this lines on the end of file [ \hardware\programmers.txt ]:

usbasp.name=USBasp
usbasp.protocol=usbasp

For now... I'm compiling my sketch on Arduino IDE and sending the hex to ArduIMU with the AVR programmer.

The FTDI cable isn't working for send code. It's working only for debugging the ArduIMU serial prints (serial monitoring on Arduino IDE or ArduIMU demo). I'm suspecting that the latest FTDI driver isn't working perfectly with the cable.
cara, pelo que vi, p/ operar com o isp, deixa aberto, desculpe, não tive chance de ler direito.
boa sorte
Pois é, Ernani... eu já fiz de tudo no avrdude, mas não acertou. Primeiro, refiz o setup do lfuse, hfuse e efuse. Depois, apaguei a memória flash e a eeprom. Por fim, regravei o bootloader. Mas, nada adiantou. Estou gravando a compilação no chip com o sketch compilado na IDE do Arduino e enviado via ISP. Muito trabalhoso, mas só assim é que funciona.

So, Ernani... I do everything on avrdude, but it don't solved the problem. Firstly, a redo the setup of lfuse, hfuse and efuse. After that, I erased the flash memory and the eeprom. Finally, I rewrite the bootloader. But, nothing happens. For now, I'm writing to the chip by compiling the sketch on Arduino's IDE and sending it through ISP. I'ts very painful, but is the only way to make it works.
se v gravou o bootloader, o isp está funcionando, nunca tentei gravar um sketch pelo isp a partir do ide do arduino, vi a opção, mas nunca usei. pelo que li, é exclusivo com o bootloader. quer uma placa ftdi? tenho de monte aqui (muito barato, não compensa a dor de cabeça de precisar e não ter), depois v me compra outra p/ repor, seilá.

esses heroismos acabam nunca valendo a pena.
Sandro, if you've reloaded the bootloader and reset the fuses, the only reason it wouldn't be loading via the Arduino IDE is either a hardware error (a soldering mistake on the FTDI pins, bad cable, or cable put in the wrong way) or a driver problem. I'd try on a different PC first.
Chris,

What driver you use for that? I downloaded the 2.06.00 combined model (D2XX and VCP) .
And yes, I tried over a fresh installed windows xp on other PC. I'm going crazy with that error...

I don't believe is a soldering mistake, I have done a detailed search for bad soldering. Having wrong pins is almost impossible, because the manual is very instructive about the assembly. Also, my soldering isn't so bad... :)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service