Greetings...  I just bought a new Futaba T8FG Super. After going through the process of setting it up with APM 3.0.1 , the ESC's/motors wouldn't arm. I checked off everything in the troubleshooting guide down to calibrating the ESCs, which I did using the "all at once" method. When I was instructed to bring the throttle down, and then apply it to turn over the motors, it worked!..... but, after I unplugged and replugged the LiPo as instructed, once again they wouldn't arm. I went through the process 3 times with the same result. (signal transmitting & receiving, radio calibration sucessful in the MP, accept throttle is also affecting the channel 6).   All was working with my old TX, just updated to this one.

I'm stuck, help appreciated !


APM 3.0.1


Futaba T8FG Super

R6208SB receiver

Views: 2255

Reply to This

Replies to This Discussion

I also have that radio. Not sure if this is your problem but I've found in most cases I have to reverse the transmitter's throttle output in order to get it to properly work with whatever I'm flying. Seems to to be something common with Futabas.


I believe that you are correct about the Futaba transmitter's throttle channel having to be reversed. I had an EX6 transmitter that did not seem to work with an airplane ESC until I read in a discussion post that the transmitter's throttle channel had to be reversed to work correctly.


TCIII ArduRover2 Developer

Do you mean to reverse the direction of the throttle ?


This section of the Arducopter Wiki explains transmitter calibration:radio calibration 

If the throttle bar gets smaller when you push the throttle joystick forward then you need to do the following:

Yes, reverse the transmitters throttle channel. There should be a menu page on the transmitter that allows you to reverse the output of the throttle radio channel.

On Futaba transmitters the value of the throttle PWM signal becomes smaller when the throttle joystick is pushed forward instead of getting bigger. The ESCs expect the value of the throttle PWM signal to get bigger, not smaller when the joystick is pushed forward.


TCIII ArduRover2 Developer

I just looked at my TF8G.  I do indeed have the throttle reversed for my aircraft running APMs. Press "LNK", then select "Reverse" and set "3 THR" to "REV". It reverses the PWM signal the transmitter sends out. I forget the details of why this needs to be done, but it's apparently fairly common with the throttle channel on Futabas. (Edit: I see Thomas has explained why this is with good detail above!!)

You throttle stick still operates as normal, with down stick resulting in minimum throttle, but the PWM signal is inverted. That may fix your problem.

Thanks for the replies...  in fact, I already have the throttle reversed on the Tx. I had done that because that's the way my old transmitter was set up. So I'm still unable to arm, accept during the last step of ESc calibration. Then unplug, replug, and no go. I did mention above that during radio calibration in the MP, all works well ACCEPT that the throttle is also mirrored in the channel 6 bar.

Any more thoughts welcomed !


Tom, since we have the same model Futaba, is there any other settings you can think of on your radio that might be set up differently on mine, that is causing the problem?

I've never used that model, but I do know that the new Futabas did break the older PPM encoder software and an update was released in March. If your APM is older than that, you should update your PPM software by following the instructions here

Mick, if you pull up "SERVO" in the TF8G linkage menu it will give you a visual display of what that transmitter is putting out on each channel. When I move my throttle, only the bar for  Channel 3 moves. That's as it should be.

It sounds like you somehow have Channel 6 also assigned to J3, which is the throttle stick. To fix that go to the LINKAGE menu and select "FUNCTION". You then get some screens that allow you assign whatever control you want to each channel. Is channel 6 assigned to J3? If so, then set it to whatever other control you want. But I'm not sure that that's what's causing your problem.

The PPM encoder update mentioned by Chris is a good idea, but it's the sort of thing that manifests itself in occasional erratic control while flying (I had this happen). Arming usually isn't a problem.

Thanks Tom, so I followed your directions and got the channel 6 re assigned. The throttle now registers on it's own ok. However, the base problem is still there. The motors just wont arm after the ESC calibration is done. The LED's don't change to arm mode. Getting a bit frustrating as I thought this bit would be straight forward !

If it's a GPS issue you could test by turning off the pre-arm check in Mission Planner. It's the first item in the Standard Parameters. If you can then arm you know it something in the pre-check.

But here's a dumb question....Are you sure your APM is in Stabilize Mode? If it's not, it won't ARM (Don't ask how I learned this). Hook up your APM via USB to your PC and look at the HUD display screen. If it's not showing the Mode as Stabilize then that's your problem. You can try arming it while watching the screen (main battery disconnected!) and it should show Armed.

I turned off the pre arm-check, no go. All modes are on stabalize, so that's not it either.  The Tx is getting through the receiver to the mission planner and calibrating no problem. I did multiple all-at-once ESC calibrations, and I just did a manual one, 1 at a time directly thru the throttle port on the receiver - all motors work... it seems to me as long as I am bypassing the APM the signal gets thru. Some setting, or thing in the APM is stopping the arming process...?

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service