I believe fence or geofence to be one of the most amazing, useful safetly features of this firmware.

Thanks for everyone's hard work to make this possible!

With fence on,

Now, when the the target altitude is reached (or breached) the copter enters into RTL mode.

It used to just STOP and not go any higher.

When did this change? what firmare?

Can there be an option to turn this back on, if not, where exactly is the code where the change occured.

Also, would it be hard to write the code to have the multicopter just "STOP" and not PASS the fence instead of RTL in the horizontal fence breach also?

Thanks

Gregory

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Yes, I see.
    Randy and Rob are working on this and will soon be corrected to just "stop" at your max altitude and not enter RTL. (It is already corrected in AC3.3 when it comes out)

    Remember we are talking about altitude only; circle (horizonal) fence limits are still RTL by design.
    • Well, the circular limits will be firm, like altitude, with 3.3.  Or at least that's the plan.

      Now to be clear, this, and the firm altitude limit, will NOT apply in Acro and Stabilize.  That would be very very hard to do.  Those modes will continue to blow through the limit, then RTL.

      • Rob, Randy,

        Talking about AC3.3  I see that "APMVERSION: ArduCopter V3.3-dev" is out at the repository.

        What happened to the downloads at http://firmware.diydrones.com/Copter

        You cannot download arducopter.hex files anymore. (tried from 3 different computers and using 3 different browsers; chrome, ie, and firefox to the same effect)

        When you click the hex file it opens a window in the browser "showing" you the 16,000+ lines of code instead of just downloading it to your computer.

        It was working for the last 2 years........what happened?

        How do you download the new firmware from the repository now?

        • Developer

          I'm not aware of any changes to the firmware.diydrones.com site but I'll ask around.

          For me, I just right-mouse-click on it and "save link as" and it'll store all that to a file which can be uploaded.

          Update: you're right!  it was a mime error on that page.  Tridge has fixed it now.  It's possible the page is still in your browser's cache so if you try again, clear the browser cache or try downloading another frame's binary.

          • Randy I want to bring this to your attention, since we spoke above, about the diy firmware repository.

            Seems that we might have a big problem but I am hoping I am wrong. I do not want to open a new topic at this point for I am hoping this is a quick fix, but upon your recommendation I will open a new topic thread if needed.
            ALL "latest releases" in the repository, firmware.diydrones.com/copter  for quad frame going back about 3 weeks (maybe longer) are downloading with some kind of bug. When you try to install a custom firmware via Mission Planner the binary (hex file) installs successfully but upon the verification process towards the end, it gives you an error such as:  "Upload successful, but verify failed: exp 94 got 0 at 1"
            To me, this is the first time such an error occurred in 2 years of testing and updating the apm's firmware.
            At other times, upon firmware update the connection is lost and the apm gets bricked. I am fortunate to be able to say that this is not an issue to me because I have an Atmel AVR programmer tool and can access the 2560 chip directly to reinstall the bootloader or a new apm hex file at will but still for the folks that do not know how to do this it is a major problem.
            To make sure the problem is not with one of my software/hardware devices, I conducted these testes multiple times, using different apm boards, different versions of mission planner and 2 different computers one with win 7 and one with win 8, all rendering the same results.
            Older hex files that are proved to be stable by me which I have saved, work flawlessly in operation and in the update firmware process.
            Also, I tried the lastest quad hex today 3-2-15 from the repository and it gives a different kind of error upon firmware update.
            I proceeded to check to see if it would upload using the at Atmel programmer directly via ISP and it states that this binary file is too big to fit in the 2560 chip. The exact quote is "Some sections of the file provided does not fit within the device memory" This is a first with the apm's hex files.
            Please advise, thanks.

            • Developer

              Gregory,

              I guess you're trying to upload to an APM2 board?  "Latest" is our latest development branch which can contain bugs.  In this case though I think you're just seeing the effect of the AC3.3-dev code not fitting onto the APM2 anymore.  AC3.3 and beyond will only be supported on the high powered CPUs like Pixhawk, Linux boards, etc.

              • I am actually in shock to hear this. This means it is over for the APM 2.X platform as far as firmware updates?

                Yes, I know they are betas but I am not talking about the latest...which technically is the one with today's date. I am referring all betas going back a few weeks which do not install correctly on the APM2+ boards anymore.

                A new APM board came out somewhat recently, the APM2.8 which corrects a lot of earlier hardware issues. On this board the Telemetry and OSD can be used simultaneously leaving the RX wire connected on both and it works fantastic. Also other hardware corrections were made meaning we got these boards working close to perfection and now it is over?

                (Also there is the Mini APM boards running the Atmel 2560 which is excellent for smaller quads)

                I need to confirm this with you Randy. So from now on all new firmware updates will not work on the APM 2.5 through 2.8 which is the most popular and mostly used board around the globe?

                This is a major game changer, was this posted anywhere letting everyone know. I haven't seen anything though out the forums. I imagine this is something a lot folks would be talking about.

                So what is the latest firmware update that is designed to work on the APM2.8?

                Did the "fixed limit" fence feature for circle which Rob mentioned earlier in this thread make it into "the last firmware that fits in the 2560 CPU? 

                • Developer

                  Gregory,

                  The APM2.x boards have served us well but it has become nearly impossible to add any new features because of limits not just in CPU speed but flash place and RAM.  I've put enormous efforts over the past couple of years into squeezing every last bit of CPU, RAM and flash out of the APM2.x and it's just become too hard.

                  This applies to ArduCopter, but ArduPlane, Rover and AntennaTracker will support the APM2 for a few more releases I expect.

                  Ardupilot is open source though so if some developer wants to join the dev team and try to continue the development we are more than happy to help them do that.

                  I think if you ask around in the forums you'll find many people have heard that the APM2.x's days are limited and most people are moving to the Pixhawk (or other high CPU boards).  I announced this about 1 year ago at DroneCon / Sparkfun AVC and numerous times on the release threads.

                  Ardupilot really is becoming more and more separate from any specific hardware.  I did not know there was an "APM2.8" board but in any case, it's not a board from 3DR (who supports and consults with the dev team) so it's really up to the manufacturers to decide if they should invest and sell a board with a limited future.

                  I'm happy to start a separate discussion to announce the limited future of the APM2.x boards if you'd like.  It really is a technical and resource decision though, unrelated to any marketing, pricing, etc of any of the board manufacturers.

                  • I understand, thanks for clarifying everything.

                    Yes, a separate topic on the fate of the APM2.x would be great.

                    Thanks again for your support.

                    Regarding a previous comment on this thread, Rob mentioned that there where plans to incorporate the fence "circle" limit in AC3.3 to simply stop the copter just as in the altitude limit.

                    Can you tell if this made it in the AC3.3 yet?  If it made it in on or before the Feb 12th beta files; based on what I see, it will still fit in the apm's 2560 memory.

                    (looks like everything under 718k still fits)

          • Maybe one of the other developers saw my question here because now the download is working.

            It was not working for about a week.

            You just left click once and it downloads instantly as it has always done.

            Can't wait to try the "fence" features.

            Thanks, Randy..........and everyone else.

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
DIY Drones via Twitter
RT @chr1sa: The US government just approved 5 US-made drones for purchase, all based on the @Dronecode @PX4Autopilot standard. Great news f…
Aug 20
DIY Drones via Twitter
RT @MarvelmindMaxim: Extreme precision for 60 swarming robots. #marvelmind #autonomousrobotics #robotics #swarmrobotics #rtls #ips #indoor…
Aug 3
DIY Drones via Twitter
RT @MarvelmindMaxim: Precise (±2cm) tracking for racing boats and autonomous boats. Works outdoor and indoor. #autonomous #AutonomousVehic…
Aug 3
DIY Drones via Twitter
RT @MarvelmindMaxim: Helping PixHawk folks to fly autonomous quadcopters using PX4 and ArduPilot. https://marvelmind.com/drones/ Equally suitab…
Aug 3
DIY Drones via Twitter
RT @davsca1: Here is the video of the performance. This paper was a huge group effort and more than one year of work, where we combined and…
Jul 16
DIY Drones via Twitter
RT @chr1sa: My talk on PX4 and FAA certification is coming up at 1:45 PST today on the PX4 Dev Summit livestream. Includes some cool new st…
Jul 7
DIY Drones via Twitter
RT @seesharp: I'm tuned into the PX4 / Dronecode free live conference. Great stuff. Microsoft AirSim talk in 10 minutes. https://t.co/0zbZ2…
Jul 6
DIY Drones via Twitter
RT @chr1sa: Here's today's best times in the @DIYRobocars/@donkey_car virtual race of AI cars compared to last month's race on the same tra…
Jun 20
DIY Drones via Twitter
Jun 19
DIY Drones via Twitter
The difference between proper RC cars and toys (when you’re turning them into robots) https://ift.tt/2MUTvxd
Jun 14
DIY Drones via Twitter
RT @Struktur3D: We have just posted on @DIYDrones for the first time in a long time. Continuing with our search for a #lasercutting service…
Jun 5
DIY Drones via Twitter
Review of the new Nivida Jetson NX for robocars https://ift.tt/36TrS0G
Jun 2
DIY Drones via Twitter
RT @chr1sa: Somehow I missed this, but last week @Nvidia released a new version of its Isaac robot development framework. Lots of new Lidar…
May 31
DIY Drones via Twitter
Welcome to the new DIY Drones design!. You may have noticed that DIY Drones looks a little different today. That's… https://twitter.com/i/web/status/1265714415137153024
May 27
DIY Drones via Twitter
New! Online Training on Drones for Disaster Response https://ift.tt/3ehdHoT
May 26
More…