Getting Pixhawk to work with Emax

It's not a new thing that people can't get the pixhawk to work with emax escs.

If someone has any solution to this problem, please post it here.

If there are no solutions, then could it be possible to make a firmware change to allow stuff people have bought to work?

(Pixhawk won't calibrate the Emax escs on boot)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hello guys,

    I know this is a very old question but i have a Pixhawk 2.4.7 and EMAX RS2205 2300kv motors. I need to buy new ESCs and was thinking of going for the Emax BLHeli Series 30A ESC(
    Has the issue been resolved?

    I saw Alireza Manzoori 's replay that it has bee resolved for the EMAX Simon ESCs, but what about the model mentioned above?

    Grateful for any help.
    BLHeli Series 30A ESC (ONESHOT available)
    BLHeli Series 30A ESC
  • Interesting update on the EMAX ESC issue with Pixhawk: The issue is apparently resolved in the new generation of EMAX Simon ESCs!

    I was making a new quadrotor and again decided to use Emax Simon ESCs despite their compatibility issue with Pixhawk (as they are by far the cheapest and most available ESC in the local stores here). Before ripping the heat shrink on the ESCs to remove the resistor and capacitor as I had done before, I decided to test them. So I attached them to Pixhawk and the motors started spinning right away!

    I think EMAX has modified the ESCs to resolve this problem finally, but maybe it's still too soon to jump to this conclusion. I have tested Emax Simon 20A ESCs with Pixhawk, Copter Firmware V3.2 & 3.3 both worked fine.

  • Well I bought my Emax 4in1 Quattro 30A prior to reading any of  these postings. Then I started to worry when I started prepping to rebuild my qaud with the pixhawk and 4in1. Wasn't to happy to attempt any soldering on a new component.

    Anyway so I tried with out it. Didn't do any changes on the 4in1.

    All I had to do was calibrate the 4in1 with the throttle hub directly to my receiver to do all four motors.

    Finished my rebuild attached all of the other electronics back on the 4in1, pixhawk, receiver, gps, and rest of my gadgets.

    Performed rest of the calibrations.

    Plugged in my battery, turned on my transmitter, and connected my ground station.

    Waited for all beeps to finished, pushed the safety switch for a sec, and then armed with my transmitter.

    Poof it all worked. All four motors started spinning. Showed ARM on my ground station. Throttled up and down worked fine.

    Then used transmitter to disarm, recognized DISARM on my ground station. 

    Link to 4in1 i used.


  • Hey everyone,

    I'm a bit new to drones, and trying to build my first quadrotor using Pixhawk. I had already purchased EMAX Simon 40A ESCs for my motors when I noticed the controversy about compatibility issues between EMAX & Pixhawk. Thanks to Aldos, I could get my ESCs to communicate with Pixhawk & arm them successfully after removing those two components (I owe you big time, Aldos. You saved me a lot of time & effort!). For the record, I have marked the components that need to be removed on Simon 40As in case someone else needs to do this:


    But now there's another problem. I do the ESC throttle calibration and it works perfectly while still in calibration mode, but when I restart Pixhawk in Stabilize mode and arm it, the motor runs at zero throttle (albeit slowly). Can anyone guess what could be wrong here?! I have tried calibrating with Pixhawk & without it (connecting the ESC directly to the Rx).

    Another issue is that if I don't hold down the arming switch (the blinky red one) right after I connect the battery, the ESCs will go into parameter setting mode...this means that the ESCs are seeing a full-throttle signal for more than 2 seconds upon start-up!

    • Dear, please let me know if I must just removed the two components, or after remove it, I have to jump the connections?
    • Developer

      see The motors spin when armed to indicate it's armed (you can disable that feature if you wish, but the it's less obvious when the vehicle is armed)

      • Yep that's right, I changed MOT_SPIN_ARMED parameter and the motors stopped spinning when armed. Thanks a lot Bill!

  • It has been frustrating getting my quad to fly with the Pixhawk (from the APM) and now I have hit this Emax ESC problem as well.

    I am thinking of

    a) removing the (pullup/pulldown?) resistor & capacitor as suggested by Aldo Vargas


    b) dead bug wiring a line driver 74HCT244 as suggested by squarepeg

    but in case I brick my Emax 25A 4in1 esc and I have to buy new ones, I was wondering how we can tell if an esc supports Pixhawk pwm at 3.3v?

    Does anyone know which esc's definitely work with the Pixhawk and wont glitch?

    • I thought I was stuck with something like 14 EMAX ESC's... but after the components fix, which by the way is easier to do than adding a driver... now i can use all the EMAX esc's.

      • Did you note any problem with the ESC's after the componentes removal?

This reply was deleted.