Getting Pixhawk to work with Emax

It's not a new thing that people can't get the pixhawk to work with emax escs.

If someone has any solution to this problem, please post it here.

If there are no solutions, then could it be possible to make a firmware change to allow stuff people have bought to work?

(Pixhawk won't calibrate the Emax escs on boot)

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

    • Hi Aldo,

      Do you say if remove these two resistors, then emax will be compatible with pixhawk?

      Do you test it? do you have any video or something?

      thanks

      • yes, remove those components, one is a capacitor and the other a resistor... after that, arming/working with pixhawk is doable.

        I dont have a video, its really and easy fix.

        good luck.

        • Hi Aldo o Hola,

          I opened mu Emax 4in1 of 30A and it's little differents than yours i don't know recognise those components

          Here i attach a photo of mine

          Can you help me?

          image.jpg

          • maybe is easier if you contact EMAX support... they might know exactly which ones to remove, with the single one is easier, this one is a bit more complex...

  • Hello,

    It now obvious that there is a problem on with this Emax 4 in 1 ESC. It seems that it does not work with the Pixhawk. Plenty of people are having this problem.
    I am trying to consolidate all the information I found on this problem.

    There are other opened posts on the same subject :
    http://diydrones.com/forum/topics/getting-pixhawk-to-work-with-emax
    http://diydrones.com/forum/topics/emax-simonk-esc-on-pixhawk-runnin...
    http://diydrones.com/forum/topics/emax-simonk-esc-on-pixhawk-runnin...
    http://diydrones.com/forum/topics/pixhawk-with-emax-4in1
    ...
    Most progress have been done here:
    http://ardupilot.com/forum/viewtopic.php?f=21&t=5784&sid=1f...

    It is very strange since the ESC has the SimonK firmware, and that every other ESC seem to work with the same firmware. It is maybe a modified version.

    Anyway, here is my config:
    -TX: Frsky Taranis (with latest fw)
    -RX: Frsky D8R
    -ESC: EMAX 4in1 25Ax4
    -Pixhawk FC with GPS (ArduCopter 3.2.1)
    -3S 3000 mAh battery

    I can indeed calibrate the ESCs when I connect them directly to the radio.
    And the Pixhawk doesn't seem to communicate with the ESCs. Somethings happen when I plug some servos to port 5 and 6 (for gimbal), but still, not motor rotation...

    I hope this can be solved quickly.
    Tony
    • Hello all,

      I took the problem the other way. I asked EMAX why it doesn't work. I wrote them an email and here is their answer:

      "The current 4 in 1 ESC 25A doesn't support Pixhawk, we had noticed that and are currently modifying the firmware and doing test so that the new firmware will be compatible with Pixhawk flight controller. We will finish test in around a week. I will keep you posted about it."

      So, hopefully, we should have some news next week.

      Tony
      • Any solution after few months? because i can't do anything... I'm think that i will change my emax 4in1 by qbrain...

      • Did you have any luck on this?

        • Waiting for the solution? :(

      • Well, finally.

This reply was deleted.

Activity

DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
More…