GPS fix. No 3D fix after update

Hi ,
this is a question regarding the 3DR ublox lea6 GPS:
after trying out several things with no success I hope for help from this honorable forum and the experienced members.

About 11 weeks ago I purchased the APM 2.5 FC board and the GPS brand new and original.
The first times I connected and run the boards together via USB on the desk to learn about the
(new to me) functions it worked fine! The MP and Firmware installed perfect and the GPS
found satellites in a few seconds.
Because of time issues I had to leave the boards for about 2 months in the drawer.

Now - restarting with my 'hexa' project I face this problem:
As I found new updates, I download the recent MP(1.2.20) and after connecting the boards
again via USB to the PC - also updated the firmware to Arducopter v.2.8.1 hexa.

And from now on, the GPS won't find and fix satellites anymore !
The red led on the GPS is solid even after 2 hours connected.
The setup, conditions and location is exactly the same as 8 weeks before (when it worked fine the first times).

Any ideas what is going on? What mistake I've made?
The APM 2.5 and GPS was kept connected together with the cable in the drawer. Did this erase something from the GPS?

Please, if someboby read through this lines and could lead me to resolve this GPS issue- would be great because I'm really stuck.

I already reverted back and forth to older versions, uninstalled and reinstalled the MP and let the board connected a long time in case the little back up battery needs a recharge but no way - can't get a GPS fix  =(

Any help is appreciated, thanks!

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.


  • My GPS problem:

     As we can see on picture, we have Satcount (8 sattelites). But seems like MP dose nothing with that info, and displays GPS: NO GPS. 

    In some mysterious reasons this happens Only with teoglas signed GPS (numbered 1 on picture).  

    Gps numbered 2 works fine (Its signed 574N). Showing GPS: 3DFIX in few minutes. 

    1. Has somebody had similar issues? (I have 2 teoglas GPS, and both have same issue)

    2. Its wierd that red wire goes to GND. Blug fits only that way. Its just wierd.


    Fullscreen capture 3.12.2012 154331.bmp.jpg
This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25