GPs Issues

It seems that I have a chronic problem getting the GPS to lock in. Often when powering up with the PIxhawk, I get hdop 100 and 0 satellites. After waiting anywhere from 3 to 10 minutes, It may or may not begin working and I get a 3D fix. sometimes I just give up because It seems to be totally dead other than seeing the the red LED is lit.

I have tried another Compas/GPS module, but the same thing happens.  I am using 1.58GB video, 1000 mw.   Could it be overdriving the GPS?

I am using the Compass/GPS ordered with the PIXHAWK.

I also am unable to write the new beta firmware to the board. I am using the USB serial, and it usually will do the erase, then will begin writing but at some point the progress bar is showing that it is writing, but randomly will stop progress and then give a timeout error.
So it leaves the board dead, but I can then load and write the 3.1 current flying firmware and bring it back to life.. I have tried different USB cables, any ideas for me to try?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Admin

    @Richard,

    You might try using a powered USB Hub as some PCs/Laptops do not supply enough current for a full up Pixhawk configuration.

    Regards,

    TCIII AVD 

    • It is definitely possible the video tx is interfering with GPS since L1 GPS is 1575mhz, not to far from 1258. Try killing the power to the transmitter and see if GPS improves. I had a 2w on 1258 over a foot away and it still severely impacted GPS.
    • Thanks, I'll give that a shot.   That is a great suggestion.  

      Do you have any ideas about the GPS issue?  , I have two Pixhawks and both seem to have flacky GPS performance.

      sometimes I power up and they work fine, but often, they take time and multiple power ups to begin making satellite connections.  the will begin showing my position in MP thousands of miles away, and keep moving every refresh until after a few minutes MP finally shows my position in my neighborhood.. Today though, after ten minutes I had to give it up and go to work..

      Thanks for any ideas..

      RE

      • Well, some success I finally got the 3.2rc5 to load, I just kept trying to upload, and it failed three times, each time the progress bar went part of the way, finally the 4th time it went all the way. 

        Now I will have to get outdoors to try to figure out the GPS issue.

        Thanks

        • Depending on your configuration it could be interference from your setup.  Mount the GPS up and away from the body.  I had the same issues until I shielding the plate my GPS mounts on with copper tape.

          • I will give that a try, on both my quads I have the GPS/Compass in front of the Pixhawk, then in front go the GPS/Compass is my Video Xmitter (1.258 GHZ)   I have been wondering about that.

            RE

            • I did find that the location of the GPS/compass was the problem.  I moved it to a "Tower" that elevated it about 6 inches, and moved it to behind the AP, further from the Antenna for the video transmitter. It now immediately acquires satellites.  moving it back to the location where is was mounted before, causes it to lose the satellites immediately.

              Thanks for the tip!

              RE

This reply was deleted.

Activity

DIY Robocars via Twitter
6 hours ago
DIY Robocars via Twitter
6 hours ago
DIY Drones via Twitter
yesterday
DIY Robocars via Twitter
RT @Heavy02011: @diyrobocars : A Home-brew computer club* for Connected Autonomous Driving on Jan 23rd, 2021 https://www.meetup.com/Connected-Autonomous-Driving/events/275728684/ #Meetu…
yesterday
DIY Robocars via Twitter
yesterday
David Hori liked Isabella Domi's profile
Wednesday
DIY Robocars via Twitter
RT @Heavy02011: ⁦@diyrobocars⁩ Autonomous Driving Assembly at #rC3. join us at https://rc3.world/rc3/assembly/diyrobocars-f1tenth/ ⁦@f1tenth⁩ ⁦@DAVGtech⁩ ⁦@DWalmroth⁩…
Monday
DIY Robocars via Twitter
RT @chr1sa: New car designs coming for our next @DIYRobocars @donkey_car virtual race on the 23rd. Choose any one you want at race time Le…
Monday
DIY Robocars via Twitter
RT @RoboticMasters: Thanks to @EllerbachMaxime and the Sydney Uni Capstone Students the @donkey_car @diyrobocars simulator is getting a ma…
Monday
DIY Robocars via Twitter
Jan 6
DIY Robocars via Twitter
Dec 28, 2020
DIY Robocars via Twitter
An interesting line-following simulator to use with with your robocars: https://github.com/ron-grant/LFS
Dec 23, 2020
DIY Robocars via Twitter
Dec 23, 2020
DIY Robocars via Twitter
An improved version of the @IntelAIResearch OpenBot: https://diyrobocars.com/2020/12/14/an-improved-version-of-the-intel-openbot/
Dec 14, 2020
DIY Drones via Twitter
An improved version of the Intel OpenBot https://ift.tt/2KkHT8Q
Dec 14, 2020
DIY Robocars via Twitter
Dec 10, 2020
More…