H-Quad spinning (yaw) on back left motor

Hi I've been building this H quad for a couple months now because of problems Withi wobbling so I figuered it was a bad esc and changed them all out. Since then I have had a number of unusual problems start effecting the quad. I messed around with the parameters and sorted most of it and all motors spin correct directions, props right way all basics covered here. The quad responds well to forward back yaw all axis working BUT, as soon as I try take off it wants to spin donuts on the rear left axis motor. So it just won't fly not without crashing. So I noticed a couple videos on utube where others had the same issue. First their H quad was spinning on all axis doing left yaws similar to mine but mines only on the one. Then the same guy says he's fixed it but I can see his quad has the same wobble as mine had at the start. Unfortunately he didn't speak or give explanations so I dont know if he fixed it or just gave up. Can someone help with respect to this problem Im having. It's becomming a joke, months to build a simple quad, I built my first in a couple weeks. Then again I have switched to 3DR APM since the first NAZA I built but I'm getting nowhere with APM either with fixed wing or quads they always have had issues on take off with pulling into turns even though everything is working correctly on the ground.

image.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Very strange, I just can't figure what's happening! I reinstalled the firmware for the must be around 6times now, and it seems to be flying, ok. It still wants to wander backwards fairly quickly but I can control it so I'm going back into parameters to see if there's a way to even out the hover so it doesn't wander backwards. I have tried to figure out the diagnostics but it's a little hard to work out. I can't find the right places to measure performance too well. I find some graphs are showing the motors but exactly what it's showing I dunno :( I did notice that I was having issues with the mode functions such as stabilise/position hold/RTh. It was showing them change as I switched my radio then after reinstalling firmware it wouldn't, I left the quad plugged in for a coffee and came back to see all modes set to stabilise again. Strange, so I reset the modes and this time it showed as I switched the radio modes. So possibly it was requiring more time to process the information even though it was showing as done. Something to keep in mind for all those like me still making do with their four year old laptops!
This reply was deleted.

Activity

DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
4 hours ago
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
5 hours ago
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Monday
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Monday
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Monday
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: Practiced at @RAMS_RC_Club today with my new @ARRMARC car https://t.co/AEu2hCx89T
Aug 28
DIY Robocars via Twitter
Aug 24
More…