Well...today was an interesting day.  I was out flying the newly rebuilt ArduCopter (quad-X) testing the 'Position Hold' setting.  It was about 40 feet in the air.  Fairly windy, with gusts up to about 10-15 MPH.  Well...it started to tumble...upside down, then right-side up, round and round.  I quickly switched it to 'Stabilized'...and it tried to right itself...but was unsuccessful.  It plowed straight into the ground...upside down, and the Ardupilot took a pretty hard hit.

Okay...so...as I take the pieces back into the office, and try to plug the ArduPilot into the computer to get the logs...it hangs on the "Got param VOLT_DIVIDER".  After it times out, I click "Details" and this is what is posted --

Timeout on read - getParamList

Received: 12 of 283 after 6 tries

Please Check:

1. Link Speed

2. Link Quality

3. Hardware hasn't hung

There are also a list of code lines listed...but I don't think they're are relevant.  Okay...so I scour the web and I see a couple other posting on the whole "VOLT_DIVIDER" issues...most are tied with someone frying the board with too much voltage.  Another said "Reload the Mission Planner software"...so I grabbed my notebook and tried connecting with it.  Nope...still hangs.

Okay, so I try updating the Firmware...and it downloads and pushes the new Firmware to the ArduPilot just fine.  I click on 'Terminal' and it connects. I can run any command (but not sure which ones I should run).

In terms of LED's -- I ONLY have a solid BLUE light in the ABC cluster, and the power LED is on (see pic attached).

So...here are my thoughts....I "think" I may have knocked a "Voltage Divider" resister loose or cracked/broke a solder joint.  The processor seems to be working fine.  The ArduPilot will power up with either the USB or the power cable....but I only ever get a Solid Blue Light...and it won't "Connect".

Thoughts?  Does DIYDrones do board repairs?  If I tear it out of the case...what should I look for? 

Thanks!

-Eric

Views: 177

Attachments:

Reply to This

Replies to This Discussion

I am having the same problem.  Did you ever find a solution to this?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service