HDOP too high! even on > 6 satellites & GPS cold start problem


1) I'm new to RC and Pixhawk. Recently, i tried reflashing a chinese M8N with Marco-Ublox_M8N.txt. After doing so, i discovered that the GPS no longer able to lock any satellite in the ublox evaluation software.

Then, i decided to revert to normal by reflashing its own config but the HDOP is not the same as before. It used to read 5 satellites for HDOP<2 but now it reads HDOP>5 even on 6 satellites.

Does anyone knows how to fix this?

2) I cant lock GPS after disconnecting the quadcopter after more than 5 mins. It needs to be connected via USB to have a lock. Only then the USB can be disconnected and GPS lock shall maintain.

My quad has TELEM2 connected to minimosd module and GPS connected to GPS M8N

M8N uses 9600 baud

Does anyone knows how to make the GPS independently lock on the quad without USB connection on cold start?

Views: 553

Reply to This

Replies to This Discussion

I had similar problem on apm 2.8. It would get gps lock after about 45 seconds,, but would not arm due to high hdop, even with 11 satellites reading. it would arm with usb connected, but not with usb not connected. it turned out that my escs were not providing enough power to apm. i added a bec between battery and apm. problem solved. gps gets lock in about 10 seconds with or without usb connected. no arming failsafes.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service