I have used a Pixhawk with Ardcopter in the "+" configuration without difficulty for the past few months.  I recently built a Cinetank (X configuration) and have had nothing but trouble getting stable flight.

I have gone over the hardware setup multiple times, ensured that all ESCs were routed to the appropriate motors, motor spin was correct, and props installed correctly.  Have calibrated multiple times.  Despite this, when I take off in stabilize mode, the copter ALWAYS takes off with a right roll requiring full left roll on the stick to maintain a stable position.  I have not even been able to AutoTune due to this severe right drift (it practically flies away).  Initially, I thought that my flight controller had taken too hard of a fall, and so I purchased a new 3DR Pixhawk which also results in the same behavior.  I don't know if the electronics (ESC, power distribution board) could affect the gryo and accelerometer readings, as they are about 5 cm below the FC.

After nearly pulling my hair out thinking this was a hardware setup problem, I installed the PX4 flightstack firmware via Qgroundcontrol and miraculously, I achieved stable hover with stock settings on the first attempt.

At this point I am at a loss as to why I can't seem to get the Arducopter flight-stack setup properly.  I assume since the PX4 Flightstack works, this is not a hardware setup problem.  I just don't know what I am doing incorrectly that leads this to such strange behavior.  When doing hand tests, the copter seems to want to settle at a 30 degree roll to the right and appropriate motors spin up to keep this position.  

I really would like to use the arducopter flight stack vs. PX4, and would appreciate any help you could offer.

I have attached a log to demonstrate this.  Thanks for your help, 


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I've solved this....It is due to a RCMAP function in Arducopter 3.2.1.  Evidently, it maps the channel, but not the trims. Therefore, the ROLL input was based on the Throttle trim,  causing the copter to roll to right on takeoff.  Rumor has it this bug will be fixed in 3.3.  In the meantime, for anyone else experiencing this, write down the trim values and manually enter them.   

    • I have the same problem with a X. Increase the throttle and it rolls to the left and becomes inverted without it leaving the ground. 
      I'm new to the Pixhawk and ask if you could provide a bit more detail how changed the RCMAP setting??

      • Hi Peter,

        First and foremost, make sure all of your ESC signal wires are set correctly, the props spin in the correct direction, props are on correctly, and the motor checks pass.  If this is the case, AND you notice that your channels are mismapped in the radio calibration screen, (ie. Throttle appears as roll etc)  and have to be remapped, then this might be what is causing your problem.  If you are using a PWM encoder instead of S.BUS, it is probably easier to just plug the correct signal wires into the encoder from your receiver rather than do a software remap.  If you had to do a software remap and you are having the problems you describe, read on.


        I found this full discussion: https://github.com/diydrones/ardupilot/issues/1661

        First, I went to the radio calibration screen and noted the min,max,and for each channel.  All four channels were essentially the same.  I then looked at the trim settings of RC1 and RC3.  The RC throttle "Trim" should be markedly lower than the others since the throttle trim is usually the min value (if you recall, they ask you to lower your throttle all the way before accepting the values in the calibration screen).,  I noticed that the Trim for what should have been my Roll RC input was minimal, so I changed that to what the Roll midpoint was.  Additionally, I lowered the RC# of what was now my Throttle to what the Roll was erroneously set at. Once you edit these values in the Full Parameter list, don't attempt to re-calibrate the radio or you have to start over again.  I proceeded to write to the new values to the board, rebooted the pixhawk, went outside and it all worked beautifully.

        The down side is that I thought my Hobbyking Pixhawk had a hardware issue and so bought a new one from 3DR.  The good news is, the 3DR one doesn't give me the Poor Accell warning, so all is good.

        Supposedly this will be fixed when they release 3.3, but I don't think the fix made it to the Beta 3.3. file yet.  You can use the above solution in the meantime.  Let me know if this is clear or you need any additional help

        • Hi Rob.

          Thanks again for your help. Your fix seems what I'm looking for and I will make some adjustment and get back to you.

          • Just had a look at all the settings and the RCMAP channels look correct and they all move correctly in the Radio calibration test. My RC Channels are Pitch 2, Roll 1, Throttle 3, Yaw 4. I have set the RC trim values for 1, 2, and 4 at the mid value and and Throttle RC3 at the minimum. This hasn't fixed the hard left roll on take off. From the above discussion it seems that the throttle and roll trims are reversed in the solftware??? So is the fix switching the RC1 and RC3 trims?
            I also notice all my props are all reversed i.e. the front right is clockwise. I expect if they are all reversed it may not matter?? Is there a fix for this?
            Any help would be appreciated.


            • Peter,

              This sounds like a hardware setup problem.  I would:

              1) Make sure your motors all spin in the correct direction


              2) Re-connect ESC motor leads as necessary to gain required motor spin.  Motor spin is determined by how you wired the motor to the ESC.  

              3) Use a servo connector to make sure that each motor number is going to the correct Pixhawk pin

              4) Confirm everything with the motor test in Mission Planner.

              5) Re-calibrate everything.

              6) Do a test..take motors off, raise throttle, make sure the right motors spin faster with left roll input from rc tx, vice versa.  

              7) Put props back on making sure that they are on the correct motors based on spin.

              8) Try again.

              I know it is frustrating, but make sure everything is attached the way it should be.

              I suspect this is a setup problem which is different from what I experienced.

              • Thanks and that all makes sense so back to the bench!



                • All working,  needed to reconfigure the motors. I was  following the instructions for the Hoverthings Flip build but I think the bit about the Pixhawk motor setup guide may need revising? Thanks for the help. 

This reply was deleted.