Developer

Hi,

I use mission planner in windows 7, never had any problem with it but today I started the update from 1.36 and right now when I try to start it shows a message that I need "microsoft framework 4.0" installed, but I've already installed 4.5 and it didn't work, then I installed 4.0 and the message continues. Why? 

Then I got another notebook that had an older 1.3x version of mission planner that was working and tried the update, then I got the same message and tried to install microsoft 4.0 and no go. 

I tried to uninstall mission planner and install it again, same error. 

Both notebooks run windows 7 (Brazilian Portuguese language) and both were working prior the update, administrator on both computers. I have a PC that has 1.48 mission planner working so I really don't know whats happening.

Thanks 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hello. I am facing the same issue now. How do I solve it? I am using a desktop and it doesn't have bluetooth, hence I cannot use the above trick. Kindly help

  • Disabling Bluetooth does fix the problem BUT surely that is a ridiculous solution, there must a better way.

  • Hi,

    I solved my issue with the Mission planner being slow on comport.
    I removed the bluetooth USB dongle that was plugged into my USB HUB and voila problem solved.
    The comports are detected very fast again like before.

    Quite strange though as the bluetooth dongle was there before and than I didn't had this problem.
    Must be causing problems after some kind of windows update.

  • I re-installed the .net framework but the problem remains.
    I do not get any error messages but the mission planner is very slow.

    e.g when trying to connect or log download, nothing happens and after about half a minute it comes to life.

    I even started of from a clean install (completely removed the previous installation).
    Today updated to version 1.2.49 but same issues.

    Tried with both USB and 3DR radio connection

    Regards

  • You need to install .net framework 4.0

    http://www.microsoft.com/en-us/download/details.aspx?id=17851

    Microsoft .NET Framework 4 (Web Installer)
    The Microsoft .NET Framework 4 web installer package downloads and installs the .NET Framework components required to run on the target machine archi…
  • Same problem here on win7 (64bit)

    Extremely slow, couldn't even load firmware onto my APM2.5 (time out).
    When using same release on win XP, no issue at all.

    How to fix or solve?

    thank you

  • Hello my friend,

    My laptop, win7, running MP 1.2.45 show the same message. But after follow this required update, it works just perfect.

    Good luck!

This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
2 hours ago
More…