Help! No heartbeat packets.

Desperately need help regarding a APM connection issue.

Last fall I put away the quad for the winter, no time to fly while going to college.
At the time, I was over parameters for compassmot and needed to buy an external mag.
Now that it's spring, I dusted off the quad and tried to pick up where I left off.
I carefully cut the trace on the APM (3) board to disable the internal mag so I could hookup the
new external mag. I also upgraded the MP to the latest version.

Unfortunately, the APM will not connect to my new laptop (Windows 8). When I hook up the USB,
The APM lights initially rapidly flash blue and red, then it will flash the red light in a double-flash

When I try to connect to MP, it will time out and I get the "No Heartbeat Packets Recieved" message.

Here is what I've tried with no joy:

1. I tried to go back one version of MP to 1.2.99

2. Went back to last working version which (I think) was 1.2.79

3. Attempted to connect with and without the battery connected

4. Attempted to connect with and without the Radio reciever hooked up

5. Tried multiple USB cables

6. Tried all my USB ports

7. Made sure I have the lasted drivers (I think this was done correctly)

8. Tried it with and without the new external mag connected

9. Made sure the baud rate of 115200 was selected

10. Bashed my head on the desk repeatedly

11. Cried myself to sleep ;)

What am I missing here? It connected fine when I left it, but now nothing.
Could it be related to the MP update, drivers or trace cut, or all three?

Thank you in advance for your help- this forum is such a wealth of information, especially in a pinch!



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Thanks, I will try that when I get home. I'm thinking you might be right. When I updated Windows 8 to 8.1 a while back my Arduino IDE stopped working. I reinstalled the IDE and still couldn't connect to my Arduino Uno to upload sketches.

    I don't know why I didn't recall that until now and put 2 and 2 together.

    I'll let you know how it goes.


    • Looking at my device manager, there are no conflicts. Arduino IDE has the latest drivers installed. I noticed, however that the Uno was listed under Com 5, not Com 3. I went back to arduino and tried to upload a sketch to my Uno on Com 5 instead, and it worked.

      Unfortunately, the Mega APM board is listed under Com 3 in MP and still won't connect.


This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21