Help! No heartbeat packets.

Desperately need help regarding a APM connection issue.

Last fall I put away the quad for the winter, no time to fly while going to college.
At the time, I was over parameters for compassmot and needed to buy an external mag.
Now that it's spring, I dusted off the quad and tried to pick up where I left off.
I carefully cut the trace on the APM (3) board to disable the internal mag so I could hookup the
new external mag. I also upgraded the MP to the latest version.

Unfortunately, the APM will not connect to my new laptop (Windows 8). When I hook up the USB,
The APM lights initially rapidly flash blue and red, then it will flash the red light in a double-flash

When I try to connect to MP, it will time out and I get the "No Heartbeat Packets Recieved" message.

Here is what I've tried with no joy:

1. I tried to go back one version of MP to 1.2.99

2. Went back to last working version which (I think) was 1.2.79

3. Attempted to connect with and without the battery connected

4. Attempted to connect with and without the Radio reciever hooked up

5. Tried multiple USB cables

6. Tried all my USB ports

7. Made sure I have the lasted drivers (I think this was done correctly)

8. Tried it with and without the new external mag connected

9. Made sure the baud rate of 115200 was selected

10. Bashed my head on the desk repeatedly

11. Cried myself to sleep ;)

What am I missing here? It connected fine when I left it, but now nothing.
Could it be related to the MP update, drivers or trace cut, or all three?

Thank you in advance for your help- this forum is such a wealth of information, especially in a pinch!



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Michael (and anyone else having these issues),

    I'm having the same issues after upgrading to Arducopter v3.15. Prior to upgrading, I was on 2.91b and everything was working fine. After moving to AC 3.15, I am still able to connect via usb to Mission planner but am unable to do so via 3DR radio telemetry. I've tried reflashing it back to 2.91b but it appears that whatever damaged caused by the firmware update is persistent. I'm having the exact same issue with 2 of the APM 2.52 boards (RCTimer) that were working perfectly fine prior to the firmware update. 

    I even tried on 6 different computers (+2 Android Smartphones) and tried running different versions of Mission Planner, APM planner 2, Droidplanner (1 & 2), Andropilot, etc. 

    I have also checked for the 3.3v regulator issue and my regulators are all working fine. I've tried CLI Setup->Reset/Erase and Tests and nothing seems to be wrong with the hardware.

    Everything I'm working on relies on MAVLink to work such as communications with ROS/Raspberry Pi for Intelligent Navigation, Computer Vision etc ... and this is driving me nuts...

  • same issue here... used to work... 3.1.5 multirotor Y6 firmware... the only thing I did different is plugging the X8R remote and GPS, suddently everything went down to hell... I can flash the board, access it via terminal so connectivity works... but I can't get through the mavlink....

  • OK, guys-

    Sorry for the long gap in posts here, it was final exams week.

    I show the exact same settings in my pc as the ones you posted.

    Still no luck, and getting real discouraged.


  • I have exactly the same problem with my APM 2.6. My brand new board was working flawlessly during 10-15 flights and then it suddenly stopped working, luckily on a table. I lost all control and connection with MP. I was not able to connect it again, tried to re-install everything, tested on different computers, but it did not help. My second APM 2.6 works well, so no problem on the computer side... I am able to install older firmware and connect it via terminal, but when I try to run the test, see the reading from the sensors etc., it fails. Nothing is burned, 3.3V regulator works normally, I have not idea what is going on.

  • Baud rate selected is 115200k.

    I'll follow this link's process when I get home from campus today. 



  • The selections in the drop down box are AUTO, COM3 Mega 2560, UDP, TCP.

    I've tried both Auto and Com3.


  • Went through and reinstalled drivers and Arduino IDE (which I need for other projects) as well as MP.

    Still no luck.

    Any other ideas?

    • Do you have any issues with the Arduino IDE communicating with something like an UNO?

      With the APM connected, when you go into the Windows 8 Device Manager, can you see the COM port assigned to the APM? Does the APM ever get a satellite lock? Can you successfully arm it? Is there any possibility the board was damaged when you cut the trace?

      I had similar 'no heartbeat' issues with the latest build of MP and my 3DR radios after updating MP to rel. 3. When I downgraded back to rel. 1.2.99 everything was fine. Probably coincidence but I won't be installing 3 again anytime soon.

      • Crady-

        Thanks for your input! To answer your questions;

        1. Yes, I can use my Uno just fine on Com5.

        2. APM is assigned to Com3

        3. I could lock satellites last time I tried, a few months ago.

        4. I have not tried to arm it, I will try that tomorrow- good idea.

        5. I was extremely careful cutting the trace and examined the board for damage before and after and it seems fine.

        Thanks- Jim

        • That Windows is assigning a COM port to the APM is reassuring. Just out of curiosity, what are the port values in Device Manager?  For reference, under Ports my APM 2.6 shows up as an Arduino Mega 2560 on COM3.

          Port settings for COM 3 report:
          Bits per second: 9600
          Data bits: 8
          Parity: None
          Stop bits: 1
          Flow control: None
          Advanced shows:
          Use FIFO buffers 'checked'
          Rx buffer is maxed at High (14)
          Tx buffer is maxed High (16)
          Driver Provider is Arduino LLC
          Driver Date: 1/4/2013
          Driver Version: 1

          Mission Planner then connects to COM3 at 115200.

          I'm running Windows 7 Ultimate 64. 

          As an aside, when I re-installed MP and the APM firmware I first blew away all the old files and folders, both in the Programs folder and in the Documents folder and uninstalled the drivers.  

This reply was deleted.