Hi,

I just tried to configure the Mid Throttle value, than everything went wrong :(

The following happened:

I tried to increase the value of Mid Throttle via the APM Planner, I updated the param disconnected from the APM and disconnected the USB cable too. After this I can't armed the motors. I tried to set back the param (though it was in the right range, I mod from 500 -> 600), same issue. It was also strange that I can't connect to the telemetry.

Than I reinstalled the firmware and did the calibrations, than I realized that I could arm the motors and they are spinning if the USB cable connected.
Another finding that in case the USB cable wasn't connected and the telemetry connected the yellow led (B) is flashing and the ESCs did not beep long (after the 3 short beep for the 3S LIPO). If I removed the telemetry cable they're beeping correctly but still not able to arm the motors without the USB connected :(

If USB connected and motors are armable I still not able to connect to the telemetry. 

I already started to think that maybe the dual LIPOs killed the power board, but I already did about 10-15 ~25min flights as test without problem. Like I did this morning too.

HW Configuration:

  • APM 2.8
  • Standard APM power module
  • dual ZIPPY Flightmax 4000mAh LIPOs
  • HP Simonk 30A ESC
  • Tarot 4006 620kv motors
  • Hexa

SW Configuration:

  • APM Planner 2.0.18 (Mac)
  • Firmware Arducopter 3.2.1

Any help/suggestion are welcome!

Views: 279

Reply to This

Replies to This Discussion

It's possible that telemetry is not working if some of the parameters were updated.  Not an indication of hardware failure.

Need to check all the parameters.

But if I just reinstalled the firmware this shouldn't be the case isn't it?

Ok I did some measurement, this may helps:

So on the ESC "side" I measure no voltage drop if the USB is not connected, but here's a video how it behaves:

APM blinking yellow till the USB get connected, than the motors can be armed. But I'm experiencing woltage drop on other power pins of the APM:

USB not connected 3.18V :

USB connected 4.92V:

So I assume it's something power related, may the APM could not boot up?

Ok I realized what's the issue:

I baked the power board and it seem the fuse 500mA Fuse on the board.

The first one could cause the low voltage -> APM won't boot up

The second one cause the it didn't get the voltage from the ESC BEC -> APM won't boot up

When I jumper the + from the output to one of the analog input:

it boot up correctly, and the telemetry also works fine. But this is just a work-a-round the problem exist.

I'll have to disassemble the drone and check if my hint's are right or not.

So one root cause could be that I didn't removed the JP1 so the high and low power circuit didn't separated. (Am I right?)

  • But what caused the power peak what (most probably) baked the power module and the fuse?
  • Any hint how should I wire it to avoid such a thing?
    Like just replace the power module and disconnect the power circuits by removing JP1 is enough?
  • Is it possible to replace the fuse (and may the diode)?

Thanks the answers in advance

And I also found a related article

The newer boards have a 1A fuse as it has better voltage drop properties. The 500mA is costuming more current as you get nearer to 500mA, so it's not the best choice. Hence its upgrading to 1A

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service