Hi folks,

One of my RFD900 radios was working fine for months but is now only showing 1 solid red LED. Using USB/FTDI, I'm unable to connect or reset it with MissionPlanner ("No heartbeat packets received") or with the 3DRRadio.exe ("Failed to enter command mode") config tool.

I've tried all the baud rates and even tried different USB ports. The other RFD900 connects just fine using the same USB/FTDI connection. 

Any suggestions on how to troubleshoot this? Or how to reset the device? 

Thanks in advance!

Phil

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • One more piece info to help anyone else that cannot connect to the radio for reprogramming. Page 4 of the "RFD900 radio modem software manual" says: 

    "In case there is need to force the modem into boot mode, short circuit" the pins "labelled CTS and GND..."

    I just tried this successfully and was able to connect and reprogram the radio. 

  • Here's a follow-up posting with the fix, in case others face this same issue.

    The simple fix that worked was to run the 3DRRadio.exe tool and click the "Upload Firmware (Local)" button. This successfully connected to the RFD900a and reloaded the firmware. The radio LEDs are now working normally (green LED blinking) and I'm able to connect, "Load Settings", "Save Settings", etc.

    • Solid red means firmware update mode.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @a1k0n: @DanielChiaJH @diyrobocars @circuitlaunch Here's my car's view of that race. About 8.4 second lap times for laps 2 and 3... both…
yesterday
DIY Robocars via Twitter
RT @DanielChiaJH: Great racing against @a1k0n today at @diyrobocars! Pretty cool to both break sun-9s at the track today I think I got very…
Sunday
DIY Robocars via Twitter
Broadcasting the @circuitlaunch race live now at https://m.twitch.tv/diyrobocars Races begin around 2:00pm PT
Saturday
DIY Robocars via Twitter
RT @a1k0n: ran a huge number of hyperparameter tuning experiments yesterday; now I can train a new policy, far with better quality, in 15 m…
Saturday
DIY Robocars via Twitter
RT @a1k0n: Did I get rid of hand-tuned parameters? Yes. Am I still hand-tuning more parameters? Also yes. I have a few knobs to address the…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: I'm not going to spoil it, but (after charging the battery) this works way better than it has any right to. The car is now faste…
Sep 26
DIY Robocars via Twitter
RT @a1k0n: Decided to just see what happens if I run the sim-trained neural net on the car, with some safety rails around max throttle slew…
Sep 26
DIY Robocars via Twitter
Sep 24
DIY Robocars via Twitter
RT @SmallpixelCar: @a1k0n @diyrobocars I learned from this. This is my speed profile. Looks like I am too conservative on the right side of…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: @SmallpixelCar @diyrobocars Dot color is speed; brighter is faster. Yeah, it has less room to explore in the tighter part, and t…
Sep 24
DIY Robocars via Twitter
RT @a1k0n: I'm gonna try to do proper offline reinforcement learning for @diyrobocars and throw away all my manual parameter tuning for the…
Sep 23
DIY Robocars via Twitter
RT @circuitlaunch: DIY Robocars & Brazilian BBQ - Sat 10/1. Our track combines hairpin curves with an intersection for max danger. Take tha…
Sep 22
DIY Robocars via Twitter
RT @SmallpixelCar: Had an great test today on @RAMS_RC_Club track. However the car starts to drift at 40mph. Some experts recommended to ch…
Sep 11
DIY Robocars via Twitter
RT @gclue_akira: 世界最速 チームtamiyaのaiカー https://t.co/1Qq2zOeftG
Sep 10
DIY Robocars via Twitter
RT @DanielChiaJH: Always a good time working on my @diyrobocars car at @circuitlaunch. Still got some work to do if I’m to beat @a1k0n howe…
Sep 10
DIY Robocars via Twitter
RT @SmallpixelCar: My new speed profile for @RAMS_RC_Club track https://t.co/RtLb7TcgIJ
Sep 10
More…