How to disable IMU sensors on Pixhawk?


I'm trying to repair my Pixhawk board after hard crash. Board was installed without plastic cover and some parts was teared off the board, also few pcb traces was damaged.

I already repaired and resoldered everything I could, except of L3GD20 and LSM303D IMUs. I'm always getting "bad accel health" or/and "bad gyro health" messages in mission planner. Sometimes values from this IMUs are freezing and sometimes not.

MPU-6000 works absolutely fine and values from it gyro/acc are ok, so I disabled IMU prearm check and made some successful test flights. 

APM boards are working fine with single MPU-6000, so maybe it is possible to disable L3GD20 and LSM303D on pixhawk board? If one of them is not soldered, my pixhawk won't boot at all. If it soldered, i'm always getting permanent IMU errors on mission planner.

How to disable it in pixahawk firmware?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25