I installed a Hitec Optima 7 Rx into my plane and reprogrammed the FS settings. I want the failsafe to kick in in the manual modes but not in Auto mode. Using the 2.4 firmware, I have GCS, short failsafe, and long failsafe set to 0. I have THR_FAILSAFE set to 1. The failsafe works as planned in manual modes but it also puts the plane into Circle->RTL in Auto mode which I dont want. How can I fix this?

 

I also posted this in the AP User Group

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I think this has been fixed in Arduplane 2.71. The release notes say that one of the improvements is "prevent control mode changes due to receiver input change when in throttle failsafe". I haven't tried this release, but it sounds like a case of problem solved at last.
  • 300km

    Hi John

    Have you had any luck with your failsafe problem? Or tested James Masterman's solution? I've searched and written a couple of posts but haven't had much in the way of help yet. I think I have the answer, but I was hoping a developer/expert would confirm it. See this post, and this older post.

    My solution is to program the Rx failsafe to set ch 8 (flight mode) to auto, similar to what James Masterman said below, (he answered my posts too, thanks James) and disable the throttle failsafe. If it goes out of radio range then the Rx failsafe will keep it in auto mode so the APM can continue the mission. This feels like a workaround to me, I expected you should be able to configure the parameters to allow this to happen.

    Note, I've only tested this on the bench so far and it works (stays in auto). I want to test it in flight this weekend.

  • Hi John,

    Not sure if you are still having this problem, but I have discovered something about failsafe with my radio that may help. When my DX7 is in Auto mode and it flies out of range, Failsafe is triggered. This was perplexing me as looking at the code, there is no way it should have gone Circle->RTL when starting from Auto Mode. The answer was in how my radio handles Failsafe.

    On failsafe, the receiver input into Channel 8 on APM was also changing along with the throttle, which meant the failsafe was inadvertently putting the APM back to manual mode. From here the normal Circle->RTL happens. The trick that worked for me was to bind my reciever with my switches already set to Auto position, this meant that on failsafe, it just stayed in auto mode and failsafe could be turned off by setting FS_SHORT and FS_LONG to 0. As far as I can tell from the code, these only have relevance in Auto modes anyway, and failsafe (Circle->RTL) is always triggered in the more manual modes (Manual/stabilise/FBW).

    Your radio may not be changing the mode setting on failsafe, but it is worth checking. You can test by connecing to mission planner, using the tuning graph on the flight data page and watching the values of ch3in (throttle) and ch8in (mode). Turn off your Tx and watch what happens to the value of ch8.

     

     

  • I know how you feel there is so much post and it seems like to little people wants to comment.
    I als has a problem and its now almost 4 days and no reply.
  • So none of the experts have any ideas as to why this might happen? The software is set to ignore throttle failsafe in Auto modes but it triggers the failsafe anyway. 

This reply was deleted.

Activity

DIY Robocars via Twitter
23 hours ago
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
DIY Robocars via Twitter
RT @SmallpixelCar: Lanenet pretty much used all my GPU power on @NVIDIAEmbedded Xavier since I optimized with tensorRT. I need to run anoth…
Sep 3
xemone liked Max Gilson's profile
Aug 31
DIY Robocars via Twitter
RT @LyftLevel5: Our @kaggle competition on Motion Prediction for Autonomous Vehicles is now live! Experiment with the largest-ever self-dri…
Aug 24
DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race will be on Sept 26th. Sign up here https://www.meetup.com/DIYRobocars/events/272786977/ https://t.co/UENKGSOWO8
Aug 24
DIY Robocars via Twitter
New ready-to-run @NVIDIAEmbedded JetRacer car from Waveshare. Perfect for the next @diyrobocars race as soon as we… https://twitter.com/i/web/status/1297960223013867520
Aug 24
More…