I have Loiter problem in V2.9.1

In v2.8 my loiter was pretty good as far as altitude hold. Now I'm on v2.9.1 and quad flies good in Stabilize but when I switch to Loiter it either drops like a rock or accelerates upwards. Throttle is about 50% for hover so I think this is good. I'm wondering how to fix before I try other flight modes. I tried Loiter at ~ 10' and then again ~ 30' with same result. Sonar is enabled and verified in raw data. I have a solid GPS lock. I tried riding out the Loiter by modulating the throttle myself and the throttle is all over the place. I have checked MP and it reports Loiter on the HUD when I flick the FM switch. Anybody else having similar problem?  Any help will be greatly appreciated.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Developer

    Jim,

         The advice on disabling the sonar is definitely a good one because it removes another source of problems.

          I imagine that the issue is vibration.  There's a advice in the trouble shooting guide here and Gary McCray has a separate vibration dampening discussion going on here.

  • 3D Robotics

    Disable the sonar (MP Hardware page) and you should be fine. The sonar can generate a lot of noise, and is only meant for low-altitude terrain following. 

This reply was deleted.

Activity

Santiago Perez liked Santiago Perez's profile
Saturday
More…