Issues with MinimOSD extra

I updated my MinumOSD firmware to the 2.4r726 , and updated the config software also to 2.3.2 r727
I like what I see, but I'm not receiving data, battery show .00, and in mission planner has all the right data, using separate telem ports on pixhawks, and both were receiving data prior to flashing the firmware and updating the config software... This has happened to two multicopters with Pixhawks.. Anybody got some insight into this one?
Thanks in advance...
RE

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I finally got the MinimOSD on the pixhawk working... sorta.

    I changed had Telemetry radio that was originally using telemetry 1, and the osd in telemetry 2 to the opposite, now the radio is using telemetry 2 and the OSD is using telemetry 1.

    The data did start flowing then on my fatshark googles.

    However there is still a problem.   When I turn on my Taranis radio, using immersion xmitter module for LRS (433MHZ) the data mostly clears off the screen leaving one artifact that looks like a "curves ahead" icon, and a number that looks like it could be a distance.  

    it is as if it changes pages to something that has not been set up.

    Once this happens, If I turn the radio back off the data doesn't return. The only way I can get the data back is to power off the Pixhawk and turn it back on.

    What is the world could be the problem?? the Taranis goes through its power up routine that checks switch positions, then beeps indicating that it has become operational and at that instant, the data goes away!

    anybody have any ideas,

    • Now it fully works!

      I finally got it working, figured out a piece at a time till it worked. first, I had to use telemetry port 1 for the OSD and telemetry port 2 for the 3DR radio. Then I had to edit the SR0 and SR1 settings to the values show above in the thread. I think at some point, it did not write those settings, the last time I tried this, I had just updated to the beta 3.2.rc9 When I clicked the write button, it acknowledged that it was written.

      Then, I went into mission planner and clicked the button to tell MP that I was using an OSD. (Im not really sure this did anything at all, there is no feedback that acknowledges the button press).

      However, then when I tried the odd out again, data began to show actual values instead of zeros.

      Then the final piece of the puzzle solving this; once I got data showing, the data overlay display seemed to go away when I turned on my RC Transmitter.. That had me puzzled for a while until I realized the radio by default was triggering the ODS to go to Panel 2, and I had nothing programed for that..

      I then used the CT tool to set up panel 2 the same as panel 1, and now, everything works as it should..
      RE

  • Is no one else having a problem getting data using MinimOSD with the Pixhawk?

    I have two platforms using the MinimOSD that no longer get any data now that I upgrade to the current firmware.

    Anyone else?

This reply was deleted.

Activity

DIY Robocars via Twitter
10 hours ago
DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
Wednesday
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…