Joystick problems first time setup


I am trying to setup a joystick to control my copters. I at least want to try it. Everything went well till I went to test it in MP on the tx radio calibration screen, none of the bars move. With the copter connected and props off I can arm/disarm and change modes (using joystick buttons) but the roll, pitch, yaw, ch7 and ch8 do not work.

I have tried different vers of MP and on 2 different copters, one a pixhawk running 3.3-rc10 the other arducopter running ver 3.2.1. I have also tried 2 different PC's nd even different joysticks one a Saitek X52 Flight Controller the other a gamepad logitech F710 same results.

any ideas?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi, I finally solved this, it was a parameter I had not been aware of, SYSID_MYGCS it was set to 253 on my copters not sure why as I don't remember ever changing it. It should be 255. Once I changed mine the joystick (RC overides?) started working.


This reply was deleted.