Hi Peeps,

I just got a AMP2.5 to play with, hoping to use it for several projects such as a camera gimbal controller, a multicopter and possible use it in a plane and boat too :)

I managed to connect over USB only and set it up for a quad firmware, I could see the GPS and attitude change. 

I had a quick play connecting a servo, but I think the servo drew too much current from the USB so it browned out.

This morning I tried to connect a 4cell nimh battery with J1 removed and it hasn't been happy since.

The board powers in USB only mode, the virtual com is visible windows device mangler, It will connect in terminal mode and responds, although I don;t know how to use that in a useful way yet.

When I connect in anyother mode it opens the connecting mavlink window, after about 26 on the countdown it flashes past a couple of things and then sticks saying "got param VOLT_DIVIDER" and then fails.

I have googled this but can't see anyone who has has had the same thing.

Can any one help please?

Thanks,

Stu

You need to be a member of diydrones to add comments!

Join diydrones

Replies are closed for this discussion.

Replies

  • Hi chaps,

    I have searched but can't find an answer to if its ok to use my APM power module at the same time as with usb plugged in at the same time....before I damage another board :).

    I am not connecting anything else at the moment, but the jumper will be removed before I power the output side with a bec,

    Cheers in advance.

    Stu

  • Hi, 6 volts is too much for the APM. It might have survived it, just be aware that there is no onboard voltage regulator and its really designed for only 5 volts.
    Try connect with CTRL-T from the planner and see if the sensors are still alive. The failure to connect the regular way still needs to be solved though, fortunately th, at cant really have been bc of the voltage overload. Yes do try w a different computer.

    Regards, Soren
  • further playing...it seems I can reflash the firware now....but it seems to get stuck on connecting at different points before and after. So it seems like a comms issue? I am going to try with my old XP laptop and see if that helps.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Our next @DIYRobocars virtual AI car race is next Saturday. Compete from home using the @donkey_car simulator -- no physical ca…
4 hours ago
DIY Robocars via Twitter
RT @RoboticMasters: Students from @Sydney_Uni working hard on improvements and changes to @donkey_car simulator. @diyrobocars @adafruit…
4 hours ago
DIY Robocars via Twitter
Practice virtual race this Saturday; the real thing will be on Oct 3 https://www.meetup.com/DIYRobocars/
Wednesday
DIY Robocars via Twitter
Wednesday
Derrick Davies liked lisa TDrones's profile
Wednesday
DIY Robocars via Twitter
Sep 21
DIY Robocars via Twitter
RT @SahikaGenc: AWS DeepRacer & Hot Wheels Track https://youtu.be/4H0Ei07RdR4 via @YouTube
Sep 14
DIY Robocars via Twitter
Sep 8
DIY Robocars via Twitter
RT @davsca1: We are releasing the code of our Fisher Information Field, the first dedicated map for perception-aware planning that is >10x…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: How this works: 1)object detection to find cones in single camera image, 30 frames/sec on @NVIDIAEmbedded Xavier. 2)comp…
Sep 8
DIY Robocars via Twitter
RT @SmallpixelCar: Use two color cones to guide the robocar. No map needed, on onsite training needed. Just place the cones and it will fol…
Sep 7
DIY Robocars via Twitter
Sep 7
DIY Robocars via Twitter
RT @roboton_io: Great to see http://roboton.io running at 60fps on the cheapest #chromebook we could find! #edtech #robotics #educat…
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Crazy in-depth article about using the OpenMV Cam for Astrophotography: https://github.com/frank26080115/OpemMV-Astrophotography-Gear https://t.co/BPoK9QDEwS
Sep 3
DIY Robocars via Twitter
RT @openmvcam: Hi folks, it's finally here! Our first draft of our Arduino Interface Library is out! It works over SoftwareSerial, Hardware…
Sep 3
DIY Robocars via Twitter
RT @chr1sa: Please let them have an open API. This would be perfect for @DIYRobocars races https://twitter.com/NintendoAmerica/status/1301513099707658246
Sep 3
More…